How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Printer and Office Tech
Category: Printers
Satisfied Customers: 10923
Experience:  11+ yrs experience, inkjets & lasers, from huge to portable
13568747
Type Your Printers Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have just installed Debian 8. Previously I have been able

Customer Question

I have just installed Debian 8. Previously I have been able to download the required driver debs and install them but in 8 I cannot. One of the drivers depends on a lib file that is no longer in the debian repositary. I have an HL2240D printer. The debian forum suggests installing the HL1250 driver which he says works perfectly. It prints OK but can't duplex which I need.
Submitted: 1 year ago.
Category: Printers
Expert:  Russell H. replied 1 year ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

The printer cannot duplex because the function is very specific, probably to the model you have... or else, the model you have a driver for is not a model that has duplex function at all. (I haven't looked up and verified this specifically. I mention it because it makes sense.)

Drivers for older Debian versions/builds may not be capable with version 8. Newer drivers will evidently be needed... unless the compiler or library or other file that is missing, can be imported workably into a Debian version that omits it.

(Or doubtfully it is left out of ver. 8, owing to a bug.)

Customer: replied 1 year ago.
Thanks. It looks as if I will have to do without duplex or go back to Debian 7. That has other problems as three websites I need don't recognize IceWeasel and the Debian 7 version won't install User Agent so I can't change the response. I suppose I could uninstall Iceweasel and install Firefox direct. Brother HL2240D can duplex but not with the Brother driver. HL1250 allows it to print but doesn't support Duplex.
Expert:  Russell H. replied 1 year ago.

That seems sensible in every respect. I approve it.

Related Printers Questions