How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Fix my Pool and Spa Your Own Question
Fix my Pool and Spa
Fix my Pool and Spa, Owner / Technition
Category: Pool and Spa
Satisfied Customers: 1100
Experience:  Over 24 years in pool and spa service and construction
30729442
Type Your Pool and Spa Question Here...
Fix my Pool and Spa is online now
A new question is answered every 9 seconds

I have a Sundance Altamar 2004, I keep getting a FLO error

Customer Question

I have a Sundance Altamar 2004, I keep getting a FLO error code, I have a newish flo switch that I have checked and it works fine and the circulation pump works fine as well. The issue seems to be that the circ pump is not coming on as it is suppose to, switching the power off and on occasionally get the circ pump going and it will work for a short time. Any ideas on the cause?
JA: How old is the appliance? Have you gotten error messages before?
Customer: It's a 2004, had this issue before and replaced the flo switch which resolved it for quite a while.
JA: Do you plan on doing the work yourself?
Customer: If possible.
JA: Anything else we should know to help you best?
Customer: Have replaced the 2 speed pump and circ pump but that was quite a while ago.
Submitted: 3 months ago.
Category: Pool and Spa
Expert:  Fix my Pool and Spa replied 2 months ago.

Do this test....Turn off breaker and remove filters from the spa completely, turn on breaker and see if the FLO goes out, if so the filter can be just dirty enough to cause the flow switch to open and cut out power to heater. You can not see the dirt on filter as it may be organic. The other issue I have seen is a clogged circulation pump, the impeller in the pump gets clogged with debris and does nt push enough water through the heater and flow switch.