How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Pontiac Technician
Category: Pontiac
Satisfied Customers: 2378
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Pontiac Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

1989 grad am 2.3. Injectors don't fire, no signal fron ecm.

Customer Question

1989 grad am 2.3. Injectors don't fire, no signal fron ecm.
JA: What is the make/model of your car?
Customer: 1989 pontiac grand am
JA: Are you fixing your Grand Am yourself? What have you tried so far?
Customer: I had a new ecm but had to use the original prom. Runs if gas is sprayed into intake.
JA: Has the vehicle turned into a gas hog? And how does it start -- same as usual?
Customer: Baught it cheap and not running. Owner gave up on it. Still idles just fone if you spray gas into the intake. Scanner shows all but injectors working. No pulse in green injector wires.
JA: Anything else you want the mechanic to know before I connect you?
Customer: That is it. Thanks
Submitted: 2 months ago.
Category: Pontiac
Expert:  david craig replied 2 months ago.

Hi Im David, thanks for visiting the site are you not using noid lights to check for injector pulse?

Customer: replied 2 months ago.
No. Just a volt meter
Expert:  david craig replied 2 months ago.

ok, a voltmeter will not tell you if the injectors are pulsing.

Customer: replied 2 months ago.
Ok. But still i got good fuel pressure at the rail and all else works. No gas thru injecors. Not any of them.
Expert:  david craig replied 2 months ago.

so you pulled the rail to verify that?

Customer: replied 2 months ago.
Then hooked up my fuel pressure gage. Plenty of gas and pressure within spec. Good spark too.
Expert:  david craig replied 2 months ago.

please answer my question, did you pull the rail up to verify that no fuel was getting sprayed from the injectors.

Expert:  david craig replied 2 months ago.

when you are cranking the engine, are you getting rpms on the tach?

Customer: replied 2 months ago.
No. After cranking over awhile and no start, I pulled the plugs. Dry. So I squited a little gas into the intake and it idles great. I can pull the injector rail I guess. To make sure.
Customer: replied 2 months ago.
I am not sure about the tach. Will have to see.
Expert:  david craig replied 2 months ago.

ok, let me know on each of those

Customer: replied 2 months ago.
The web site apeered like you be an expert at quad 4s. I thought you may be familiar with this problem giving me a shorter time to fix . I can diadnose more from here. Thanks anyways.
Expert:  david craig replied 2 months ago.

quad 4"s ,,,,,,,,,,been working on them a long time ....Ive been working on cars for 35 years dude. A shorter time to fix? are you kidding me. its called troubleshooting or are you not familiar with the concept? good luck

Customer: replied 2 months ago.
I am familiar. The precious owner had all new sesors put on it and it didnt change a thing. I changed the emc. All that is left is the prom. I know its hard doing this over text. Just thought you may have seen this before. No disrespect and have a good day. I'll get it eventually.
Expert:  david craig replied 2 months ago.

if you have no pulse the computer is failing to supply the command. new computer or not