How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Pontiac Technician
Category: Pontiac
Satisfied Customers: 2378
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Pontiac Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

When I turn the key on no pump sound the lock comes on and

Customer Question

when I turn the key on no pump sound the lock comes on and gos out and coms on again and stays on
JA: Is the car in "Park" or "Neutral?" Do you know if your car has a "wheel lock" feature?
Customer: the car is in park no sure about wheel lock feature
JA: What is the model/year of your Pontiac?
Customer: 2005 sunfire
JA: Are you fixing your Sunfire yourself? What have you tried so far?
Customer: yes I am fuel pump and ignition moudule
JA: Anything else you want the mechanic to know before I connect you?
Customer: the car is a standerd 4 speed
Submitted: 3 months ago.
Category: Pontiac
Expert:  david craig replied 3 months ago.

Hi Im David, thanks for visiting the site, does the engine crank at all?

Customer: replied 3 months ago.
it crank over fine
Expert:  david craig replied 3 months ago.

are you getting rpms while cranking?

Customer: replied 3 months ago.
No rpm when I crank
Expert:  david craig replied 3 months ago.

its not even jumping?

Customer: replied 3 months ago.
When I turn the key on to crank it jump blow 0 and back again
Expert:  david craig replied 3 months ago.

ok. and when you turn the key on you cant hear the fuel pump running for a couple of seconds?

Customer: replied 3 months ago.
No I don't here the fuel pump
Expert:  david craig replied 3 months ago.

well i would say thats your problem. youve replaced the pump already?

Expert:  david craig replied 3 months ago.

did you bother to make sure the pumps connector was getting power to it before replacing it?

Customer: replied 3 months ago.
I replace the pump when I take the relay out ther is power at the relay I jump wire with the relay out and I could the pump
Customer: replied 3 months ago.
With the on should I get power to one wire on the crankshaft sensor
Expert:  david craig replied 3 months ago.

your fuel pump not running has nothing to do wit the crank sensor

Customer: replied 3 months ago.
When I crank the engine the in injecter not pusing
Expert:  david craig replied 3 months ago.

are you using a noid light?

Expert:  david craig replied 3 months ago.

check the highlighted fuse

Customer: replied 3 months ago.
I am using noid light
Customer: replied 3 months ago.
What mean by highlighted fuse
Expert:  david craig replied 3 months ago.

the fuse on the attachment i sent

Expert:  david craig replied 3 months ago.

??

Customer: replied 3 months ago.
Fuse r ok
Customer: replied 3 months ago.
Not spark no fuel pump
Expert:  david craig replied 3 months ago.

check the crank sensor voltage, ground and signal.

Customer: replied 3 months ago.
no signal to the crank sensor
Expert:  david craig replied 3 months ago.

no voltage? because the signal come FROM the crank sensor. you have to connect the connector and backprobe it while cranking

Customer: replied 3 months ago.
with a test light key on I won't get any signal
Expert:  david craig replied 3 months ago.

correct. the engine needs to be rotating

Customer: replied 3 months ago.
Ok thanks
Expert:  david craig replied 3 months ago.

have you rechecked it with the engine cranking?

Customer: replied 3 months ago.
No not yet wating for someone crank will I check it
Expert:  david craig replied 3 months ago.

ok

Customer: replied 3 months ago.
Still no singnal from the crankshaft sensor when cranking over took the top of and check the spark on spark plug with spark tester no spark
Expert:  david craig replied 3 months ago.

no signal from crank sensor? = bad crank sensor

Expert:  david craig replied 3 months ago.

hows it going?

Customer: replied 3 months ago.
I can't get any respount from PCM on code's noting
Expert:  david craig replied 3 months ago.

the pcm isnt communicating?

Customer: replied 3 months ago.
That's right not getting anything
Expert:  david craig replied 3 months ago.

is it ecen powering up?

Customer: replied 3 months ago.
power going to PCM and there is power to injeckes's and there power to ignition control module
Expert:  david craig replied 3 months ago.

no, is the scan tool powering up?

Customer: replied 3 months ago.
it is power up it's say's no communication
Customer: replied 3 months ago.
Fuse all good
Customer: replied 3 months ago.
it's power up
Expert:  david craig replied 3 months ago.

Pcm

Customer: replied 3 months ago.
it's power to PCM and power to everyting else except crankshaft sensor
Expert:  david craig replied 3 months ago.

I am going to open this up to others. I havent anymore ideas.