How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Pontiac Technician
Category: Pontiac
Satisfied Customers: 28763
Experience:  17 Years Pontiac Technician and training.
14928985
Type Your Pontiac Question Here...
Pete is online now
A new question is answered every 9 seconds

2001 bonny 3800 When I start up it revs to 1500 to 2500 rpm,

Customer Question

2001 bonny 3800 When I start up it revs to 1500 to 2500 rpm, let it warm up still dose not drop . Turn key off, restart goes to normal idle, this also happens in drive while driving. CK lite on says tps installed new not the problem .all sensers under hood new almost all
Submitted: 11 months ago.
Category: Pontiac
Expert:  Pete replied 11 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Are you still seeing a fault code for the TPS sensor issue even after it was replaced and the code was cleared out?

Let me know so we can continue,thanks Pete.

Customer: replied 11 months ago.
Expert:  Pete replied 11 months ago.

Does your scan tool display engine data signals at all or do you have a multi meter to test electrical with at all?

Customer: replied 11 months ago.
multimeter
Expert:  Pete replied 11 months ago.

Test these wires at the TP sensor and let me know what you come up with:

Gray/black wire for 5 volts DC with key on

Black wire for ground with key on

Do this with the sensor unplugged and we can continue.

Thanks Pete

Customer: replied 11 months ago.
4.986 volts
Customer: replied 11 months ago.
I think I will go get scaner tool down at the corner
i think it would be best
Expert:  Pete replied 11 months ago.

O.k.,now plug in the connector and using the multi meter put the ground lead to ground and take the positive lead of the meter and probe the 3rd wire in the sensor connector back probing with the sensor connected.Then with the key on and engine off see if you read around .5 volt with the throttle closed then slowly open the throttle by hand and see if the voltage slowly increases to around 4.5 to 5 volts and let me know.

Thanks Pete

Customer: replied 11 months ago.
3 v to 4.96 seemes to be working
Expert:  Pete replied 11 months ago.

O.k.,so the sensor is working properly and the voltages are all o.k. this indicates that either the 3rd signal feed wire you just tested has a break in it leading back to the PCM itself and the wiring needs traced and inspected for any issues with it needing repaired or that the PCM has an internal fault needing replaced.I have seen the PCM fail on this model in the past before needing replaced for this issue here as it seemed to be a common fault.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 months ago.
new pcm less than 5000 mi ago diden`t change
Expert:  Pete replied 11 months ago.

If there is no excess play in the throttle shaft/plate the only other reason I would see that the TP sensor code is setting is if there is a break or damage to the feed/signal wiring running from the TP sensor to the PCM itself.I would check this wire and see if any issues are found.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.Your 5 star rating is appreciated

Thanks Pete

Customer: replied 11 months ago.
Had chev dealer program ,1st time ran even worse, 2nd time ran a little better, now here we are, this was a new unit
Expert:  Pete replied 11 months ago.

What is the TP code number that is setting?