How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Pontiac Technician
Category: Pontiac
Satisfied Customers: 2378
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Pontiac Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I have a 2007 G6, we had codes that showed the injectors

Customer Question

I have a 2007 G6, we had codes that showed the injectors needed serviced. We serviced the injectors with the motorvac injector cleaner, then we got a exhaust cam position sensor error. We replaced the exhaust cam position sensor. The car will not start. We have communication to to computer via a Modis. It has multiple codes. We have also tried the relearn procedure for the key. We have checked power to computer and fuel system, have also checked fuel pressure. The car cranks, but no start
JA: Do you have a scan tool to read the codes?
Customer: A Modis from snap-on, as I said there are multiple codes
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: We are an automotive repair shop that has not ran into this issue. As I said, we flushed the injectors, replaced the exhaust cam position sensor, checked for power to computers an fuel system. We also checked fuel pressure
JA: Anything else you think the mechanic should know?
Customer: Our mechanic that is working on this car has 45 plus years of experience and is stumped by this. If you need I can get all the codes. The inital codes were p1174, p0300, p0014
Submitted: 1 year ago.
Category: Pontiac
Expert:  john aka eaut replied 1 year ago.

did it run on arrival?

Customer: replied 1 year ago.
but not well
Expert:  john aka eaut replied 1 year ago.

has a compression test been performed?

Customer: replied 1 year ago.
the mechanic says there is compression in all cylinders
Expert:  john aka eaut replied 1 year ago.

even?

Expert:  john aka eaut replied 1 year ago.

injector pulse? spark?

Customer: replied 1 year ago.
Expert:  john aka eaut replied 1 year ago.

what motor? you sure it didnt jump time? did he physically put a compression gauge on it?

Customer: replied 1 year ago.
It is the 2.4, there is spark from the spark plugs and he has fuel pressure. It is in time and yes he did put a compression gauge on it.
Expert:  john aka eaut replied 1 year ago.

is the fuel contaminated? are the injectors spraying? will it run off spray in the TB?

Customer: replied 1 year ago.
No the fuel is not contaminated, spraying into the TB did not make it run, How can we check if the have pulse?
Expert:  john aka eaut replied 1 year ago.

noid lights...

Expert:  john aka eaut replied 1 year ago.

you sure it has good spark?

Customer: replied 1 year ago.
The spark plugs all have spark, we are checking the injectors
Expert:  john aka eaut replied 1 year ago.

if your are spraying fuel and they have spark it should fire

Customer: replied 1 year ago.
We know that it should fire, we have located our noid lights and they do not fit this car, we will have to locate one that does.
Customer: replied 1 year ago.
Can't get a noid light until tomorrow. Thanks for trying to help
Expert:  john aka eaut replied 1 year ago.

make jumpers...

Customer: replied 1 year ago.
We got the car to run by replacing the exhaust cam position sensor again, you only asked us to recheck things we had already checked. Thanks anyway we got this