How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tool Hut Your Own Question
Tool Hut
Tool Hut, ASE Certified Technician
Category: Pontiac
Satisfied Customers: 550
Experience:  Owner of a mobile diagnostics company assisting auto technicians with difficult vehicles
77480539
Type Your Pontiac Question Here...
Tool Hut is online now
A new question is answered every 9 seconds

Sorry took so to get back to you. I was in a accident and

Customer Question

Sorry took so long to get back to you. I was in a accident and was off work. My boss sent the G5 to the former GM dealership and we just got it back. Not sure what they did but now I can't communicate with the ECM using a scanner. They (GM tech)claimed
they couldn't communicate with the ECM when they got the car. Funny thing is I was able to communicate with the ECM before car was sent to them. My shopkeeper is down and I need a diagram for the DLC. Can you help me out?
Submitted: 1 year ago.
Category: Pontiac
Expert:  Eric replied 1 year ago.

HI,

here you go

Customer: replied 1 year ago.
Thanks, ***** ***** I got going. 08 grand prix no start. No power coming from computer to starter relay. Ignition switch was replaced and changed nothing. Thought it was the body control module so sent it to GM Guys to get replaced and programmed. Before leaving here I was able to communicate with the ECM. They could not so they say they did nothing. Now I see I have no milk lite when turn key on. Was checking fuses and one 2 amp fuses lights up my power probe but it goes green/red/green and keeps flashing. On connector number X3 I have in port B5 2 brown wires and with connector unplugged it flashes green on my probe. Does not stay constantly on. When connector is plugged in and key on port B12 2 gray wires it will flash red/green. I don't think this is normal. The 2 ports are listed as B5 Acc. Voltage and B 12 is instrument panel supply voltage. Why is my probe flashing from ground to hot?
Customer: replied 1 year ago.
X3 is connector at body control module and so is 2am fuse.
Expert:  Eric replied 1 year ago.

Hi,

sorry, my software has crashed and spent all day without luck getting it back. I will have to opt out and see if another expert can help you

Customer: replied 1 year ago.
Ok thanks
Expert:  Tool Hut replied 1 year ago.

Hi, My Name is ***** ***** for posting your question to just answer. I am a ASE Certified Master Auto Technician with 20 years experience. I am confident we can resolve your problem together.Please remember I don't know your skill level. I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies to get to a satisfactory resolution.I also try to give all of the information you may need expecting a positive rating.

What kind of scanner are you using? Do you a regular lest light?

Customer: replied 1 year ago.
Tried three different scanners. OTC, snap on-Modus and a tech 2. Yes I have a regular old style test light.
Expert:  Tool Hut replied 1 year ago.
What are results of test with regular test light?