How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Pontiac
Satisfied Customers: 8149
Experience:  Since 1975
12769047
Type Your Pontiac Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

I have a 09 vibe that runs but feels like it starved if you

Customer Question

i have a 09 vibe that runs but feels like it starved for fuel if you punch the gas falls on its face then i get misfire in cilyinder 1 turn key off it goes away go slow will run up to 80 miles per hour missfire does not show on scanner and cannot put in check mode did put in new fuel pump no change allso unplug numb 1 coil when missfireing an plug back in miss goes away at idle turn off key same thing
Submitted: 1 year ago.
Category: Pontiac
Customer: replied 1 year ago.
have not got an answer from you yet do you need more info ken
Expert:  rpmdiag replied 1 year ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident we can resolve your problem together. Please understand that I don't know your skill level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in return. I will also continue assisting you after you have rated me, if necessary. If there is any reason I cannot get a positive rating, please let me know why “in advance”, so I can go another direction for you. I am sorry you’re having this problem; I’ll help you through it.

Check the fuel pressure and volume with a gauge, check the filter, and check the exhaust for blockage. Also check the MAF sensor for being dirty inside.

Thanks, Ron

Customer: replied 1 year ago.
did so not the proublem it is late will contact you in morning thanks ken
Expert:  rpmdiag replied 1 year ago.

Ok ken,

Thanks

Ron

Customer: replied 1 year ago.
you dont seem to understand this car has had 2 new pumps put in in the last month 1 in florida an i did 1 not a fuel pump it is som,think in the ignition system you can drive the car for 10 miles its fine then it seem to lose ignition power to pcm or pcm is bad when driving it will start to missfire put it in nutrail coost restart it an it will run fine for a few more miles other times it has no power at all restart then it is fine i to have been in this busness since 1975 i own my own shop since 1990 i know its somthing in the ignition but what im not sure ken any suggestions?
Expert:  rpmdiag replied 1 year ago.

Ok, you need to use your lab scope and start testing the ignition components then. Then you will isolate the problem that way if you are not getting good data from your scan tool. Also, try mode 6 on your scan tool. That always helps too.

Ron