How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marc Your Own Question
Marc
Marc, Plumber
Category: Plumbing
Satisfied Customers: 1127
Experience:  Plumbing heating & home maintenance contractor
50715266
Type Your Plumbing Question Here...
Marc is online now
A new question is answered every 9 seconds

I cleaned the salt bridge and emptied the tank. I put some

Customer Question

I cleaned the salt bridge and emptied the tank. I put some water in the tank and pressed the recharge butten. It does not draw water from the tank, My name is ***** ***** you help solve this problem?
JA: How long has this been going on? And how severe is the problem?
Customer: The softener has not been working for several months and the bridge was was thick and took several times using warm water to brake it up
JA: Do you plan on doing the work yourself?
Customer: Yes if I can. is there a screen or possibly a clogged intake
JA: Anything else we should know to help you best?
Customer: No it just does not seem to recharge, there is no salt just water in the tank
Submitted: 1 month ago.
Category: Plumbing
Expert:  Rick replied 1 month ago.

Welcome to Just Answer, my name is ***** ***** I will do my best to help you with your issue. If my initial response doesn’t answer your question then let me know and we can continue our conversation.

You have to put salt pellets in the brine tank.

Expert:  Rick replied 1 month ago.

If the system is not drawign water out of the brine tak then you need to clean the venturi. There should be instructions to clean it in your manual.