How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rick Your Own Question
Rick
Rick, Construction Supervisor
Category: Plumbing
Satisfied Customers: 21546
Experience:  Licensed Master plumber with 40+ yrs. experience.
94766
Type Your Plumbing Question Here...
Rick is online now
A new question is answered every 9 seconds

I have a Model RETE-13 water heater. Was working fine till a

Customer Question

I have a Model RETE-13 water heater . Was working fine till a few days ago . The green light on the front is not on . The unit has 220vac and shows 110vac at the thermal overload . Any suggestions as what if anything I can do before I send back to the manufacturer .
Submitted: 8 months ago.
Category: Plumbing
Expert:  Rick replied 8 months ago.

Welcome to Just Answer, my name is ***** ***** I will do my best to help you with your issue. If my initial response doesn’t answer your question then let me know and we can continue our conversation.

Do you have the troubleshooting guide?

Customer: replied 8 months ago.
No
Expert:  Rick replied 8 months ago.
Customer: replied 8 months ago.
I have voltage from ground to both heating elements. Also 110vac at the top and bottom of the overload. Still no green light . Heat to max , no green or red lights .
Expert:  Rick replied 8 months ago.

What do you read for voltage across the 2 element terminals?