How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask AssuredElectrical Your Own Question
AssuredElectrical
AssuredElectrical, Home Specialist
Category: Plumbing
Satisfied Customers: 4241
Experience:  35 years home improvement
53189252
Type Your Plumbing Question Here...
AssuredElectrical is online now
A new question is answered every 9 seconds

I own a Whirlpool Energy smart water heater and the second

Customer Question

I own a Whirlpool Energy smart water heater and the second new programing pad WILL NOT unlock, even if I hold it for 30 minutes.
Submitted: 2 years ago.
Category: Plumbing
Customer: replied 2 years ago.
I own a Whirlpool Energy Smart water heater, model number ES50R123-45D and both of the new Energy Smart Modules (ESM) WILL NOT unlock, when pushing it for the 3 seconds or more as required.After touching the pad to turn the light on, I can touch any of the other icons, ie, Operational Mode Buttons, Temperature Up/Down Buttons etc, and the Lock Icon will flash, telling me, "unlock it dummy." However, when touching the Lock Icon, it will not unlock.Note: Both of the new Energy Smart Modules the manufacturer sent, DO NOT have a ground wire, like the one I'm replacing, and the manufacturer claims they don't need one.
Customer: replied 2 years ago.
Note: There are no codes being displayed.
Expert:  AssuredElectrical replied 2 years ago.
Welcome. My name is ***** ***** would be glad to assist.Does the water heater work fine with the ESM disconnected and using the Electronic Thermostat by itself?Does the thermostat have the normal Green light on? Let me know and we can continue,Thanks
Customer: replied 2 years ago.
Hello Tommy,Yes to both questions.
Customer: replied 2 years ago.
All three questions actually; however, the element icon does cycle on and off using the ESM which seems normal.
Expert:  AssuredElectrical replied 2 years ago.
Ok,So the ESM is actually working properly, just it is locked and you cannot access any functions?What is the set temperature of the water? And it appears the water is that temperature?It is really sounding as though they have an issue with the ESM units, maybe a fault in a batch production run.
Customer: replied 2 years ago.
The set temperature of the water is 130F.This is what the ESM reads.Yes the water seems to be 130. It feels the same as it has in the past for showers/dishes/washing hands etc; however,I have not checked with a thermometer.A bad batch sounds probable. This is two in a row sent from the company in about a one week time frame.
Customer: replied 2 years ago.
To confirm your first question, yes the ESM seems to work great, except the ability to unlock and access the functions.
Expert:  AssuredElectrical replied 2 years ago.
Ok, thanks for the added information.Based on what is taking place, the unit operating properly but staying in the Locked mode, points to the ESM itself as the issue.It sounds like they have some bad programming in the Eprom chip in the unit.That would have the design features and programming abilities. Much like a PC but just less functions.I have seen this in some compact controllers before where the factory did not have the correct bits set in the program and they would not track set points. Yours is working fine at the temperature that is already in the set point, so it leads only to the Lockout mode and function. I would definitely contact the manufacturer with all your data on the situation, cannot believe they have not seen this yet with others.Could be just an upgrade in the software and compatibility to older ET units also, but either way, it is their issue to resolve. Thanks