Oldsmobile

Oldsmobile Questions? Ask a Mechanic for Answers ASAP

Ask an Expert,
Get an Answer ASAP!

Oldsmobile
This answer was rated:

I have a 2001 Olds Alero and I have a p0452 code fuel

pressure sensor low voltage so...
I have a 2001 Olds Alero and I have a p0452 code fuel pressure sensor low voltage so I hook up a scan tool not a expensive one but tells basics and Im getting 0 volts on my scan tool for the fuel pressure sensor. Its a three wire system reference wire thats gray, a signal wire thats green and ground wire thats orange so I checked the reference wire gray and get 4.99 volts I took the leads off my scan tool and jumped the reference wire gray to the signal wire green and I get 5 volts so that tells me the signal is good all the way to the pcm ( I cut a door in the floor to access the fuel pump). I audible the ground wire and it sounds on my multimeter so im assuming the ground is good so I came to the conclusion the fuel pressure sensor was bad I bought a fuel pressure sensor and put the new one in and I cleared the code with the scan tool I turned the engine on and the MIL light stayed off for a minute then it turned back on what else could it be? The PCM itself is bad pls help. THANKS
Show More
Show Less
Ask Your Own Oldsmobile Question
Answered in 2 minutes by:
10/14/2017
KALAMYKID
KALAMYKID, Shop Owner/ Tech
Category: Oldsmobile
Satisfied Customers: 4,555
Experience: I HAVE OWNED MY OWN SHOP FOR OVER THREE YEARS. I HAVE THE TOOLS AND SOFTWARE TO ANSWERE ALMOST ANY Q
Verified

You did not have to open a new question. I can still help you on the one we where working on. Did you do the ohms test on all three wires all the way back to the pcm plug?

Ask Your Own Oldsmobile Question
Customer reply replied 1 month ago
I did a omhs test to the pcm and all the wiring is checking out good. You helped me on a fuel pump question on my 1997 buick lasabre just wanted to let you know that u told me the furl pump was bad and you were right it was the fuel pump Thanks you

Did you check the ohs readings between the three wires as well? You can test all three of them against each other if you have the pcm unplugged as well as the sensor, at the sensor plug, but you need to test them on the pcm plug as well. Then test each wire to a ground please.

Ask Your Own Oldsmobile Question
Customer reply replied 1 month ago
ok ill get back thanks

Thank you.

Ask Your Own Oldsmobile Question
Customer reply replied 1 month ago
A quick question when I unplugged my pcm and plugged it back in all my lights are on the brake light the anti-lock light my fuel guage isnt reading anymore and my radio says calibrate. Do I just have to drive it to recalibrate and they will go off on there own or do I need to do something? Thanks

Did you disconnect the battery before you unplugged the pcm?

Ask Your Own Oldsmobile Question
Customer reply replied 1 month ago
No
Customer reply replied 1 month ago
I will next time for sure

That should reset everything, the bcm did not loose power, and lost com with the pcm when you unplugged it. When you reconnect the battery everything should work correctly.

Ask Your Own Oldsmobile Question
Customer reply replied 1 month ago
ok thank u

You are very welcome.

Ask Your Own Oldsmobile Question
Customer reply replied 1 month ago
I checked the three wires from the fuel pump pressure signal to the pcm they check out and checked to ground and that was fine also

The next thing to do is to cut the pig tail off of the old pump for the ftp sensor leaving as much wire as possible. plug everything back up but the ftp sensor. Plug the pig tail from the old pump up to the ftp sensor. strip the ends of the three wires and twist them tight so the wires is stronger. The slide the wires into the new plug for the ftp sensor so we can do the next test. Make sure to put the wires from the old plug into the new plug in the correct order. Let me know when yu have this done and we can do the next test.

Ask Your Own Oldsmobile Question
Customer reply replied 1 month ago
Ok
Customer reply replied 1 month ago
I put the new connector on the ftp at the gas tank.

I am so sorry. I have been up with a customer for two days and had to get some sleep. Pull the dark green wire out of the old connector so you can test it, but leave the other two wires in the plug so they get power from the pcm. With the ignition switch on, what is the voltage to the dark green wire?

Ask Your Own Oldsmobile Question
Customer reply replied 29 days ago
I'm sorry I've been busy also got family and kids and understand you do to and. Just whenever you can help its appreciated thank you. I'm getting 0v at the dark green.

Everything says that the sensor is bad. You have the voltage going to the sensor, but nothing coming out of it. Did you apply vacuum to the sensor with the pig tail connected so you can test test the green wire?

Ask Your Own Oldsmobile Question
Customer reply replied 29 days ago
I did and still nothing I dont know I replaced the ftp sensor with a new one from autozone and still nothing and then I changed the pcm with a new one from protech auto computers and still showing the code. Thanks for all your help I'm trying to rate your 5 stars on this but its not letting me.

What size engine does your car have in it? I'm not ready to give up on this, so if you want we can keep working on it.

Ask Your Own Oldsmobile Question
Customer reply replied 29 days ago
Its a 2.4L everything I've done was telling me the ftp sensor and I changed it and the pcm and the code still on. I dont if my luck is that bad where the the 3rd ftp sensor is defective.

Set your meter to dc volts and with the ignition switch in the run position, hold the red test lead to the gray wire, and the black lead to the orange wire with a black strip and tell me what the voltage is please? With the sensor unplugged.

Ask Your Own Oldsmobile Question
Customer reply replied 29 days ago
Hey just wanted to let you know doing what you just said I get 5v. I dont know what I did but I jumped the reference gray 5v wire to the signal green wire I was getting 0v until I just jumped it then with it jumped im getting 5v on the green. So I put my scan tool in and with the car to on I erased the codes then I rechecked the car and got a p0453 ftp voltage high now so I erased that code with the jumper unplugged and I restarted the car and now I'm getting no code and the mil light is off the cars been running for 10 mins and the code is still not comming on

Now that is very odd. Lets see if the code comes back after you drive it a little bit.

KALAMYKID
KALAMYKID, Shop Owner/ Tech
Category: Oldsmobile
Satisfied Customers: 4,555
Experience: I HAVE OWNED MY OWN SHOP FOR OVER THREE YEARS. I HAVE THE TOOLS AND SOFTWARE TO ANSWERE ALMOST ANY Q
Verified
KALAMYKID and 87 other Oldsmobile Specialists are ready to help you
Ask your own question now
Customer reply replied 29 days ago
Thanks for all your help Idk like I said I jumped the gray reference 5v and green was at 0v but with it jumped the green then went to 5v so with it jumped I turned the car on and hooked up my scan tool and the p0452 code ftp low voltage went off and a p0453 code voltage high came on so I took the jumper off and with the car still on I erased the p0453 voltage high and started the car and the mil light and codes didnt come on and its been running still not on im going to drive it for awhile and let you know if it comes back on. I honestly dont know why it did what it did but it worked im lost but ill let you know thanks for all your help thank you

You are very welcome.

Ask Your Own Oldsmobile Question
Ask KALAMYKID Your Own Question
KALAMYKID
KALAMYKID
KALAMYKID, Shop Owner/ Tech
Category: Oldsmobile
Satisfied Customers: 4,555
4,555 Satisfied Customers
Experience: I HAVE OWNED MY OWN SHOP FOR OVER THREE YEARS. I HAVE THE TOOLS AND SOFTWARE TO ANSWERE ALMOST ANY Q

KALAMYKID is online now

A new question is answered every 9 seconds

How JustAnswer works:

  • Ask an ExpertExperts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional AnswerVia email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction GuaranteeRate the answer you receive.

JustAnswer in the News:

Ask-a-doc Web sites: If you've got a quick question, you can try to get an answer from sites that say they have various specialists on hand to give quick answers... Justanswer.com.
JustAnswer.com...has seen a spike since October in legal questions from readers about layoffs, unemployment and severance.
Web sites like justanswer.com/legal
...leave nothing to chance.
Traffic on JustAnswer rose 14 percent...and had nearly 400,000 page views in 30 days...inquiries related to stress, high blood pressure, drinking and heart pain jumped 33 percent.
Tory Johnson, GMA Workplace Contributor, discusses work-from-home jobs, such as JustAnswer in which verified Experts answer people’s questions.
I will tell you that...the things you have to go through to be an Expert are quite rigorous.

What Customers are Saying:

Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help.

Mary C.Freshfield, Liverpool, UK

This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!!

AlexLos Angeles, CA

Thank you for all your help. It is nice to know that this service is here for people like myself, who need answers fast and are not sure who to consult.

GPHesperia, CA

I couldn't be more satisfied! This is the site I will always come to when I need a second opinion.

JustinKernersville, NC

Just let me say that this encounter has been entirely professional and most helpful. I liked that I could ask additional questions and get answered in a very short turn around.

EstherWoodstock, NY

Thank you so much for taking your time and knowledge to support my concerns. Not only did you answer my questions, you even took it a step further with replying with more pertinent information I needed to know.

RobinElkton, Maryland

He answered my question promptly and gave me accurate, detailed information. If all of your experts are half as good, you have a great thing going here.

DianeDallas, TX

< Previous | Next >

Meet the Experts:

Dave Nova

Dave Nova

Oldsmobile Tech

597 satisfied customers

ASE Master Certification. GM World Class Certification

GM Tech Cam

GM Tech Cam

Oldsmobile Certified Technician

405 satisfied customers

14 years Automotive experience all with Gm.

Gary

Gary

ASE Certified Technician

180 satisfied customers

over 25 years as a GM master tech

Ron Z.

Ron Z.

- Olds Tech -

150 satisfied customers

18+yrs experience. State Inspector & Olds Diagnostics/Repair

George H.

George H.

ASE Certified Technician

146 satisfied customers

ASE Certified and dealer trained 15+ years

jazzmaster

jazzmaster

ASE Certified Technician

142 satisfied customers

I have 32 years experience as a automotive tech,plus ase certified

Tim Mohr

Tim Mohr

ASE MASTER

128 satisfied customers

30 YEARS EXPERIENCE, FORIEGN AND DOMESTIC, GAS AND DIESEL

< Previous | Next >

Related Oldsmobile Questions
1999 olds achieves replaced battery now the security won't
1999 olds achieves replaced battery now the security won't allow the car to crank. Tried using the 3 ten minute key memory reset, multiple times. Also tried turning the key on and letting the security… read more
rpmdiag
rpmdiag
High school
7,109 satisfied customers
I get U1040 code? Reset it and it comes right back, Code
yes with neighbors help. Checked al fuses and relays and read faults … read more
AMEDEE
AMEDEE
AUTOMOTIVE TECHNICIAN
Vocational, Technical or Trade Scho
9,105 satisfied customers
I have a 1998 Oldsmobile Bravada. It's making a noise like
I have a 1998 Oldsmobile Bravada. It's making a noise like my turn signal blinker is on when it is not. When I step on the brakes it stops. What is the problem and what is the fix? … read more
tim37857
tim37857
Mechanic
High School or GED
71 satisfied customers
1981 Olds 98 having trouble with temperature control inside
1981 Olds 98 having trouble with temperature control inside car. heater core changed & engine is operating at normal temp. adjusting lever from hot to cold doesn't seem to change anything. … read more
roy
roy
Associate Degree
3 satisfied customers
I have a 1990 olds dela 88 royale brougham. sometimes it
i have a 1990 olds dela 88 royale brougham. sometimes it starts and runs fine sometimes i will run and idle for 5-10 mins and die. there are often times it'll drive and suddenly stall. then not start.… read more
Michael Solis
Michael Solis
243 satisfied customers
I have a 2001 Olds Alero I have a p0440 code coming up what
I have a 2001 Olds Alero I have a p0440 code coming up what does this code mean and what would I do to try and fix the problem?… read more
Gary
Gary
ASE Certified Technician
Vocational, Technical or Trade Scho
180 satisfied customers
A friend's 2000 Olds Bravada has some goofy electrical
Hello, a friend's 2000 Olds Bravada has some goofy electrical problems going on … read more
AMEDEE
AMEDEE
AUTOMOTIVE TECHNICIAN
Vocational, Technical or Trade Scho
9,105 satisfied customers
Blinkers not working (working sometimes), is ok, fuse is ok,
blinkers not working (working sometimes), flasher is ok, fuse is ok, lights are ok … read more
Jaybird61
Jaybird61
Master Automotive Mechanic
1,888 satisfied customers
The 2004 Oldsmobile alero will crank for a second then
the 2004 Oldsmobile alero will crank for a second then stop.I have replaced starter,battery is new,and starter relay is clicking. … read more
KALAMYKID
KALAMYKID
Shop Owner/ Tech
4,555 satisfied customers
I have removed the gas tank on my '36 Olds to repair the
I have removed the gas tank on my '36 Olds to repair the sending unit. The car has an electric fuel pump which is quite new and has always functioned well. I replaced the inline canister-type fuel fil… read more
fordguy4u
fordguy4u
Automotive Tech
Vocational, Technical or Trade Scho
70 satisfied customers
I have 1999 olds intrigue initial problem car would crank
i have 1999 olds intrigue initial problem car would crank but would not start.after reading engine code it read a bad crank sensor, I replaced the sensor car still didn't start, then replaced plugs an… read more
AMEDEE
AMEDEE
AUTOMOTIVE TECHNICIAN
Vocational, Technical or Trade Scho
9,105 satisfied customers
My name are. I have a 99 Oldsmobile 88 (don't know if it is
Greetings, my name are Thomas. I have a 99 Oldsmobile 88 (don't know if it is LS or other) The car has 41,000 miles. Car was garaged most of the time. My problem started when the brakes completely fai… read more
eauto
eauto
self employed
High School or GED
74 satisfied customers
Front lights wiring harness was cut missing the location of
front lights wiring harness was cut missing the location of two plugs … read more
heavy_chevy_396
heavy_chevy_396
Vocational, Technical or Trade Scho
2,518 satisfied customers
1993 Date/time display all lights & screching noise. Pulled
1993 Date/time display all lights & screching noise. Pulled #6 fuse, display went out, noise disappeared. Drove 30 minutes, noise returned. … read more
Chris (aka - Moose)
Chris (aka - Moose)
Vocational, Technical or Trade Scho
108 satisfied customers
I have coolant in the oil of a 99 olds intrigue 3.5L. What
I have coolant in the oil of a 99 olds intrigue 3.5L. What is the cause? … read more
Lou P. master tech
Lou P. master tech
Mercedes Benz master tech
Bachelor's Degree
649 satisfied customers
When driving it seems like it is going to die out and is
When driving it seems like it is going to die out and is jerky … read more
AMEDEE
AMEDEE
AUTOMOTIVE TECHNICIAN
Vocational, Technical or Trade Scho
9,105 satisfied customers
My car wont start the mechanic saqys its my6 security system
my car wont start the mechanic saqys its my6 security system and casnt nothing be done unlesws I take4 it to the dealer … read more
sprinkles08
sprinkles08
Technician
High School or GED
11 satisfied customers
I have a 1980 cutlass supreme 5.0, at first it was having
I have a 1980 cutlass supreme 5.0, at first it was having trouble starting, then all the sudden it started to bog down while driving if I srped the gas pedal. I was able to press the gas pedal less an… read more
heavy_chevy_396
heavy_chevy_396
Vocational, Technical or Trade Scho
2,518 satisfied customers
Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Disclaimer: Information in questions, answers, and other posts on this site ("Posts") comes from individual users, not JustAnswer; JustAnswer is not responsible for Posts. Posts are for general information, are not intended to substitute for informed professional advice (medical, legal, veterinary, financial, etc.), or to establish a professional-client relationship. The site and services are provided "as is" with no warranty or representations by JustAnswer regarding the qualifications of Experts. To see what credentials have been verified by a third-party service, please click on the "Verified" symbol in some Experts' profiles. JustAnswer is not intended or designed for EMERGENCY questions which should be directed immediately by telephone or in-person to qualified professionals.

Show MoreShow Less

Ask Your Question

x