How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mechanic01 Your Own Question
Mechanic01
Mechanic01, ASE Certified Technician
Category: Nissan
Satisfied Customers: 977
Experience:  Owner at Baltic investments
99232115
Type Your Nissan Question Here...
Mechanic01 is online now
A new question is answered every 9 seconds

All of a sudden truck ran wierd. a bit smokier than before

Customer Question

All of a sudden truck ran wierd. a bit smokier than before and battery died. than replaced battery. it also died. than changed distributor. no spark. but lots of fuel.
JA: Has the vehicle turned into a gas hog? And how does it start -- same as usual?
Customer: its not running at all at this moment
JA: What is the model/year of your Nissan?
Customer: 2003 extera just ordered a new ignition module.it was acting u
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: yes. just got it. ran fine. removed front lights was about to lift it 2 inches did nothimg to the electrical so its wierd
JA: Anything else you want the mechanic to know before I connect you?
Customer: well the antytheft i was wondering if it could cause the no spark
Submitted: 2 months ago.
Category: Nissan
Customer: replied 2 months ago.
Bought the truck recently. according to ex owner it was running well. some issues with the ignition switch. i have ordered a new one, i started to remove front grill and lights to modify. lifting it to fit 33" tires. didn't do the lift yet. But just moving it around i found the battery dead next day. it was wierd because i didn't leave any lights on. got new battery. also went dead. than checked amp drain and it showed 0.18 which is probably normal. but when truck was sitting i heard a wierd noise under truck and i found the fuel pump running with ignition off and keys out.
Expert:  Mechanic01 replied 2 months ago.

Hello my name is ***** ***** I will be assisting you with all of your vehicle questions today. Give me one moment while I review your question and come back with a answer. Please be aware I do not know your skill level or abilities so I will be asking a lot of questions and in a lot of cases we will respond to each other quite a lot before we find a solution. As far as phone calls are concerned that is the system prompting you, not me, and they do cost more money, I prefer text but in some cases a phone call is required.

Customer: replied 2 months ago.
Changed distributor assy. did not solve the problem. still not able to get it running. next will be replacing the ignition switch that i have ordered from nissan. i have to replace it anyhow.
Expert:  Mechanic01 replied 2 months ago.

are you getting any codes?

Customer: replied 2 months ago.
I think it can not be a big issue since it was running fine. as the battery went dead i am not sure if the factory alarm may cause some electrical issues to the sparks not happening
Customer: replied 2 months ago.
or the faulty ignition switch
Customer: replied 2 months ago.
any way i can by pass the factory alarm to eleminate the complication?
Customer: replied 2 months ago.
Since i have removed the headlight assy i thought it may cause something in the alarm not working proprly so i have pluged it back. but still no start
Expert:  Mechanic01 replied 2 months ago.

there is no way to remove the alarm system, have you scanned it for any codes?

Customer: replied 2 months ago.
i have pluged in a obd but only emmision code came up
Customer: replied 2 months ago.
no other fault codes
Expert:  Mechanic01 replied 2 months ago.

is your obd able to communicate with bcm ?

Customer: replied 2 months ago.
i have no i dea. it recognized it and scaned it.
Customer: replied 2 months ago.
i have a obd2 Innowa 3100
Expert:  Mechanic01 replied 2 months ago.

are you having a red key come up on the dash?

Customer: replied 2 months ago.
no
Expert:  Mechanic01 replied 2 months ago.

then you dont have a security issue, but with the no start and all these problems you should have some sort of code coming up

Customer: replied 2 months ago.
i will try it again
Customer: replied 2 months ago.
nothing stored in memory and nothing comes up
Expert:  Mechanic01 replied 2 months ago.

So right now you have no spark at all?

Customer: replied 2 months ago.
Ok. So i have diagnozed the distributor faulty. Its running now. Well. Thanks for help.
Expert:  Mechanic01 replied 2 months ago.

sure thing, let me know if you have any other questions.

Customer satisfaction is my number one goal. Giving me a 5 star rating would be appreciated very much .You can do this rating at the box on the upper right hand corner. This will not close our chat session and at no extra charge we will still be able to talk about any other issues you may have for free! Providing a rating is the only way I will receive credit for my work with you.