How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 621
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

2003 xterra 220k, While driving, started to lug in 3rd gear

Customer Question

2003 xterra 220k,
While driving , started to lug in 3rd gear then 4th, RPMS went up and down. Car would sputter and move fwd herky jerky. Turned off car Could turn on car afterwards but rpms rev'd w/ out pressing on gas, from 700 to 1500ishChecked air filter( took off) opened gas cap, still ran bad and died.
Battery was fine, headlights worked etc.
Disconnected MAF sensor and still wouldnt turn over
Sparks were changed out 4 months ago, cap and rotor and wires, newer air filter with no obsttruciton
MAF was cleaned as well throttle body about 4 months ago, ran fine sinceTried to turn over car and could hear a click from starter and dash would flash but sounded like it ran out of gas ( half tank left of 5 day old gas from Sunoco) tried pumping the pedal but no effect ( temp was 80 degrees so no frozen fuel lines)Towed home, let it sit overnight, this morning turned it on and heard fuel pump spin up and car started with no issues and RPMs were steady at 800.Fuel pump has never been replaced, filter changed out 80k ago
Submitted: 2 months ago.
Category: Nissan
Expert:  Clifton B. replied 2 months ago.

hi is the service engine soon light on ??

Customer: replied 2 months ago.
but it was for a knock sensor issuet(p327) hat has been pr e exising for 3 years on the Xterra. If you google knock sensor for the Xterra ( non Super charged) you'll see its a "false" code. I did a knock sensor bypass about 3 months ago that didnt resolve it ( placed a knock sensor on top of the manifold and spliced the wires) If you google you can see its a common remedy. There has been no issues with the Xterra since the code popped up 3 years or since the bypass other than a drop in mileage about 1 mpg from 19 to 18. acceleration has been fine etc. In addition it using a K&n air filter ( 3 months new) with no issues and the resonator was removed as well
Expert:  Clifton B. replied 2 months ago.

ok os the car do not start now?

Customer: replied 2 months ago.
that's the funny thing.. I had it towed home yesterday ( 3 miles), wouldnt start at home, same issue, starter clicked but felt like no gas being delivered yesterday afternoon
Went to start it this morning to specifically confirm fuel pump was not spinning by listening for it while starting ( took off rear seats, pump is underneath) and it started no issues, RPMs were steady at 800, no sputtering or "starving" sound.
Customer: replied 2 months ago.
went to work in my other car, let it sit. confirmed battery connections were all tight with no corrosion as well.
Expert:  Clifton B. replied 2 months ago.

this sounds like a problem with the distributor but if the car now runs good there is no real way of saying what is the problem . I would start it and let it get hot and see if the way it runs changes .

Customer: replied 2 months ago.
checked the dist.. no issues like bad bearings or such( no powder etc) yesterday as well
Customer: replied 2 months ago.
also cap and rotor were replaced with spark plugs and wires 3- 4 months ago
Expert:  Clifton B. replied 2 months ago.

you really need the car to ack up for us to fine the problem