How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 621
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

Each time I start my 2006 350z 6spd I have drivability

Customer Question

Hello, Each time I start my 2006 350z 6spd I have drivability issues untill it warms up. Its hard to explain. but in low gears, if I take my rpm up higher than 4k rpm it sort of hesitates, chokes or bogs down, then I hear a pop sound and the car lunges forward.Its almost as if there is oil that accumulates while driving and I need to "blow it out" then it drives fine. So I need to take it to redline once or twice in 2nd or 3rd gear to get all the crap out from when it was sitting for a few hours. Lets say I am in 5th gear and I go to accelerate at half throttle, it bogs down and pops, so I throw it in 3rd, floor it till it blows crap out then I can drive normally. THere is no CEL on, I have an aftermarket MAF, intake manifold + tune.
Additional notes, Nissan has asked me to replace my engine and pay $8k due to oil consumption. I go through a qt or two ever 500 miles or so. I do have a powertrain warranty but it wont be covered unless the dealership takes out my pistons, if the rings are broken I get a new engine, if not, I pay for everything. But I wasnt having this problem before when I first noticed my bad oil consumption.
JA: Does the light stay on, or does it blink?
Customer: there is no CEL
JA: Are you fixing your 350Z yourself? What have you tried so far?
Customer: No i dont know if i can fix this myself, I have tried using thicker oil such as the lucas oil stop leak. but I have a feeling its possible that i ahve some sort of oil blowby build up somewhere that isnt freed untill I blast my car to redline, then its fine.
JA: Anything else you want the mechanic to know before I connect you?
Customer: Last year I gave her a tune up and replaced my trans& dif oil, Dont think that has affected my problem, I performed this work a year before the problem arose. I havent checked my spark plugs either.
Submitted: 8 months ago.
Category: Nissan
Expert:  Tom replied 8 months ago.

If you put the stock maf back in I bet your issue go away. Let me know.

Customer: replied 8 months ago.
Why would my MAF have issues and then work fine once its warmed up? The MAF is just a heated wire that emits a voltage differential as air flows over it. If its not working right it doesnt work right. theres no way the MAF sensor "wakes up" after redlining it and then it works fine.
Customer: replied 8 months ago.
Apparently I am paying $40 for this so dont yank my chain.