How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 615
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

I replaced the ecm and have the problem with the same engine

Customer Question

I replaced the ecm and have the problem with the same engine code po450. I disconected the battery replaced the ecm, reconected the battery started it, had no engine light, turned it off, turned it back on and the engine light came back on. Went and had the engine light checked and same code po450
Submitted: 8 months ago.
Category: Nissan
Expert:  Jay replied 8 months ago.

Hello my name is ***** ***** thank you for your question.

I am currently working today. Can we continue this later this evening? Say around 6pm EST?

Customer: replied 8 months ago.
Expert:  Jay replied 8 months ago.

In the mean time, here is the complete diagnostics for that code.

https://dl.dropboxusercontent.com/u/105565483/2a.pdf

Customer: replied 8 months ago.
That part i replaced, most diagrams show it underneath the truck on driver side by rear wheel and it looks exactly like that in the diagram. Nissan shows that part to be a Boost Sensor #25085-1s707 oem. EVAP control system pressure sensor is #22365-1s oem is in engine compartment passenger side across aircleaner.
Expert:  Jay replied 8 months ago.

Did you follow the diagnostic steps I provided with the information?