How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Bagley Your Own Question
Peter Bagley
Peter Bagley, Toyota mastertech
Category: Nissan
Satisfied Customers: 822
Experience:  master tech at Toyota dealer
24571351
Type Your Nissan Question Here...
Peter Bagley is online now
A new question is answered every 9 seconds

Has no power under load no lights on reset timing to specs

Customer Question

has no power under load no lights on reset timing to specs changed maf checked cat not plugged has new distributor , fuel filter plugs look good has about 186 k
JA: Is the fuel filter an external one, or is it inside the tank?
Customer: external under hood
JA: What is the model/year of your Nissan?
Customer: 1996 gxe auto trans
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: yes so far i set the timing cleaned the maf checked the plugs prior owner did the distributor and the fuel filter change did think the timing chain had been replace
JA: Anything else you want the mechanic to know before I connect you?
Customer: i did pull off the cat and drove it around the block still the same problem no power on load
Submitted: 1 year ago.
Category: Nissan
Expert:  Peter Bagley replied 1 year ago.

Hello and welcome to just answer and allowing me to assist you. There are a few things you may do to find or resolve this problem. check the fuel pressure at the fuel rail should be over 35 PSI , next do a proper injector flush this makes sure the injectors are spraying properly. After you do those items and it don't help totally we can get into checking both the TPS sensor and the MAP sensor for performance. Hope this gives you a start to resolving your issue and if you require further assistance I'll be happy to do so.

Customer: replied 1 year ago.
Wasn't any of what you suggested. Plugs and wires solved the problem.
Expert:  Peter Bagley replied 1 year ago.

That was a bit misleading as you said plugs were ok and new distributor? any way happy you got the problem fixed that's the main thing, cheers.