How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 621
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

Got a Nissan Pathfinder 2008 4.0L some times wont started

Customer Question

Got a Nissan Pathfinder 2008 4.0L some times wont started and get the codes from the cam sensor then replaced and also replaced crankshaft sensor and still sometimes wont star no codes then after maybe 3 or 5 times let it rest and start what the problem any idea
Submitted: 1 year ago.
Category: Nissan
Expert:  Jay replied 1 year ago.

Hello my name is ***** ***** thank you for your question.

Where are the sensors located you replaced and where did you buy the sensors?

Customer: replied 1 year ago.
nissan dealer and the sensor are the cam sensors and crankshaft sensor
Expert:  Jay replied 1 year ago.

Do you still have the old sensors?

Customer: replied 1 year ago.
I do
Expert:  Jay replied 1 year ago.

look in the electrical part of the sensors and let me know if any have oil in them

Customer: replied 1 year ago.
None are clean inside
Expert:  Jay replied 1 year ago.

Were you able to get the Cam Sensor lock to fully snap out when you plugged it in. Here is a example video.

Let me know..

https://www.youtube.com/watch?v=U7stRE6f5Ko

Customer: replied 1 year ago.
Sr I did snap it the proper way Im skilled Mechanic but Im a Journeyman Electrician. Im not tipical customer.
Expert:  Jay replied 1 year ago.

If we go back to before you changed the sensors. Did you have a Cam Sensor code?

Customer: replied 1 year ago.
I did had it start whit bank 1 and after 1 day later of replaced get the bank 2 code never get a code for crank sensor but I changed because keep the same problem won't start no codes now
Expert:  Jay replied 1 year ago.

Do you recall the exact codes?

Customer: replied 1 year ago.
I do P0340 and P0345 Battery fine grounds fine and alternator fine I got a bad feeling about the computer what do you think
Expert:  Jay replied 1 year ago.

How many miles are on the truck?

Customer: replied 1 year ago.
133724
Expert:  Jay replied 1 year ago.

Has the spark plugs been changed? Also if you give it a little gas, will the truck start right up?

Customer: replied 1 year ago.
I changed will be 2 years and no don't start pump it gas
Expert:  Jay replied 1 year ago.

you don't pump the gas, just see if it starts up with no problem if you step on the gas pedal a little bit. If it starts up fine, that could indicate the throttle chamber has to much carbon build up and needs to be cleaned. With this type of throttle chamber, you want to use MAF sensor cleaners since it's a electronically controlled. You will also need to do a Idle Relearn after you clean it as well. But lets give that a try and let me know..