How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Nissan
Satisfied Customers: 23000
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Nissan Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

1994 sentra the relay above the junction box behind the fuse

Customer Question

1994 sentra the relay above the junction box behind the fuse block is clicking rapidly and the battery and brake lights on the dash flash accordingly
JA: Many things can cause a car to make those weird sounds. Some simple, some complicated. Fortunately, the mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer: The clicking/flashing speeds up as I slow the engine or lessen the electrical load
JA: Are you hoping to fix this yourself?
Customer: Yes
JA: Great! What have you tried so far?
Customer: All I have done is identify the relay making the noise but don't know what it is for
JA: Is there anything else the Nissan Mechanic should be aware of about your Nissan?
Customer: Nop
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Nissan Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: Nissan
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

I'm not really showing any relays in the area you described. The timer module is to the right of the junction block but no relays are called out in the service information that are in that area but not in the junction block itself.

Are you able to upload a picture of the relay you're seeing?
If you remove the relay then the clicking and other symptoms stop?