How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 20399
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
10181755
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

I have a 2003 Nissan maxima 6 speed, I have no power to my

Customer Question

I have a 2003 Nissan maxima 6 speed, I have no power to my ecm connector under my radio, and my security and abs lights are on solid, all my fuses and relays are good and I have no communication to the computer through the obd2
JA: A security light issue can be an easy fix, once you get all the information you need. Luckily, the mechanic I'm going to connect you with knows all the ins and outs of the issue. Are you hoping to fix this yourself?
Customer: yea ive been working on it for awhile with no luck
JA: Great! What have you tried so far?
Customer: replaced and tested all the fuses and relays and replaced my battery ground wire
JA: Is there anything else important you think the Nissan Mechanic should know about your Nissan?
Customer: during a jumpstart I had the car running and a friend of mine pulled the main battery cable off of the terminal and then jammed it back down onto the terminal and it arced and then all these problems happened
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Nissan Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: Nissan
Expert:  peterpete190 replied 1 year ago.
Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay. Can you tell me which pins you were testing for power at the ECM? Let me know,thanks Pete.
Customer: replied 1 year ago.
I tested all of them, none have power
Expert:  peterpete190 replied 1 year ago.
Can you gain access to the wiring at the electronic ignition switch at all to do some testing?
Customer: replied 1 year ago.
yea we haven't tested that but what kind of test should we run and by ignition switch you mean where I put the key in
Expert:  peterpete190 replied 1 year ago.
This would be the switch that attaches to the key cylinder and sends out electrical signals.it should have battery voltage on one wire at all times at this switch with the key on or off.If it does then when the key is switched on see if you have power out of two wires.If you do not then the ignition switch itself was damaged with the arc that occurred and needs replaced.This powers the ECM.If this is found o.k. let me know. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 1 year ago.
I believe the key cylander is fine, we will test it anyways just to be sure but it does crank over so I believe it is in working condition
Customer: replied 1 year ago.
and where would I plug in my Nissan consult interface? I got one and haven't found the plug its not near my fuse box and wont fit in the obd2 port
Expert:  peterpete190 replied 1 year ago.
The consult 2 is the one used on this model here and it plugs into the data link connector under the dash as shown here. https://www.dropbox.com/s/h0v56dqt1wm55oj/dlc-05-09.gif?dl=0 This is the exact location that the consult 2 plugs into there is no other connection I double checked this on your model here.Here are the exact instructions for that picture above. 1. Turn ignition switch "OFF". 2. Connect "CONSULT-II" to the data link connector. I would test the ignition switch signals and see if the switch was damaged needing replaced here as this can be common.Check for any major power fuses in line from the battery cable or a large mega fuse at the under hood fuse panel for being blown as well. Let me know if you need anything else and feel free to rate my help here. Thanks Pete
Customer: replied 1 year ago.
we have no power to the ignition switch, we have power to the obd2 and no communication to the computer
Expert:  peterpete190 replied 1 year ago.
Are you receiving power at most all fuses under hood in the under hood fuse panel?
Customer: replied 1 year ago.
I have power to all the fuses but not to the inhibit relay at the fuse block near the battery
Expert:  peterpete190 replied 1 year ago.
There are some larger 40,60 and 80 amp fuses are these all o.k.?
Customer: replied 1 year ago.
they are all good
Expert:  peterpete190 replied 1 year ago.
And these larger fuses do have power am I correct?
Customer: replied 1 year ago.
all fuses have power, all fuses are good, all fuses and relays have power and have been tested and are good
Expert:  peterpete190 replied 1 year ago.
This is a tough one for me to answer myself here but others here may have more info on this.I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.Thanks Pete
Expert:  Jay replied 1 year ago.
Hello my name is ***** ***** thank you for your question. Do you have a Test light and or a Volt Meter? There should be 3 wires at the OBD2 power that have power. I would like to check all wires at the OBD2 connector and check them for power. I would also like to use a test light to double check all fuses with the key On to verify all fuses are good. Let me know..
Customer: replied 1 year ago.
I have both test light and volt meter, checked all fuses with test light, tested all relays with 9v batt., obd2 port had power at one I believe I'm at work or I'd test it right now
Expert:  Jay replied 1 year ago.
when will you be at the car to check the OBD2 port for power?
Customer: replied 1 year ago.
Not until 6am, I tested it and it's only got power at one pin
Expert:  Jay replied 1 year ago.
Ok.. What is your schedule for tomorrow? I work during the day. Would it be possible to work on this issue tomorrow night? I can keep this question open till you are able to work with me. Just let me know what day you are available.
Customer: replied 1 year ago.
Wendsay and Thursday I'm free
Expert:  Jay replied 1 year ago.
Done!.. I am online around 7 pm EST. So I will be online then to continue to help you. Will that work for you?
Customer: replied 1 year ago.
Yea that will work wensday at 7
Expert:  Jay replied 1 year ago.
Ok.. Talk to you then. Just reply back to this question when you are online, and I will reply to you as soon as I get online..