How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, import technician
Category: Nissan
Satisfied Customers: 7065
Experience:  import Technician . Shop Owner ,. 27 years experience,
29331485
Type Your Nissan Question Here...
Greg is online now
A new question is answered every 9 seconds

Idle problems with my Nissan A33 engine rough idle when

Customer Question

Idle problems with my Nissan A33 engine rough idle when shifting to drive on a warm engine on a cold engine usually even on park and neutral shift idle will usually drop and engine will die tried changing spark plugs, checked ignition coils and fuel pump but problem still persists
JA: Thanks. Can you give me any more details about your issue?
Customer: That's basically what I've done tried doing
JA: OK got it. Last thing — Nissan Mechanics generally expect a deposit of about $20 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Nissan
Expert:  Greg replied 1 year ago.

Is the check engine light "ON" when the engine is running .

How many miles on this engine .

Did you check for malfunction codes . if not check and let me know.

If the check engine light is not "ON" then have your Mechanic clean out the Throttle body as a build up of carbon in the throttle plate will cause you this issue that you are having .

Also if all is good and no Engine malfunction codes, then check for transmission codes, as a bad Torque converter will also cause this issue ..

Need any follow up help then please get back to me with the reply button, and not the poor or bad service.
This way i can get back to you or suggest another expert if needed.

If i do not get back to you then i may be off line, and when i get back online i will get back to you..

Your deposit does not pay me until the answer is rated in a positive way,
Not rating or a bad rating does not constitute a refund.

If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .

Kind regards Greg.

Customer: replied 1 year ago.
Hi Greg
No check engine light is on and milleage is about 62,000 miles . I had also had it run through a computer diagnostics no error code can be found but the service crew told me it might be crankshaft position error is this possible? Btw im from the phillipines and this type of model here is not so popular that is why im doubting thier expertise here Thank you for your timePaolo
Expert:  Greg replied 1 year ago.

Hi .

If the crank sensor was the problem you would have a relevant code .

Most likely issue you have without any malfunction codes could be the following.

Fuel pressure low.

Idle control Valve .

Throttle body gunked up with carbon deposits on the throttle plate (Very common check this first before replacing parts) .

If not already done have then remove and clean the throttle body ..Idle control is also part of the throttle body this should be cleaned also .

Rgds Greg

Customer: replied 1 year ago.
Ill try that as soon as possible greg ill get back to you
Expert:  Greg replied 1 year ago.

Okay sounds good .

Let me know what the outcome is .

Rgds Greg

Customer: replied 1 year ago.
Hi greg sorry for the late reply i am too busy with work but today i had a chance to have my car checked.. It seems that my trouble is related to a crank shaft sensor i had it diagnosed and a code p1336 seems to appear.. My mechanic changed the crankshaft sensor but the problem is still there idle is still droping when we shift to drive he suggested that i use fuel additives to try to clean injectors .. Still trying to solve the problemBy the way code was erased shen the sensor was changed
Expert:  Greg replied 1 year ago.

Did you use a OEM sensor as said an aftermarket sensor on Nissan's rarely work .

Greg

Customer: replied 1 year ago.
Yup oem sensors
Expert:  Greg replied 1 year ago.

hi .

What year was this nissan Maxima /Cefiro?

Greg

Customer: replied 1 year ago.
Here in the philippines is 2006
Expert:  Greg replied 1 year ago.

Thank you .

Just to be sure we are with the same engine as the maxima do you have a distributor on this engine .

Greg

Related Nissan Questions