How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Clifton B. Your Own Question
Clifton B.
Clifton B., ASE Master Auto Tech
Category: Nissan
Satisfied Customers: 4007
Experience:  ASE Master Certified Tech, Nissan Master Certified Tech, 12 yrs. experience in auto repair.
6166830
Type Your Nissan Question Here...
Clifton B. is online now
A new question is answered every 9 seconds

2004 maxima. Problem with a/c, radio and navigation unit

Customer Question

2004 maxima. Problem with a/c, radio and navigation unit
Submitted: 2 years ago.
Category: Nissan
Customer: replied 2 years ago.
When the problem occurs the a/c functions, but you can not change any settings. The radio is inoperative. The LCD is black. If you disconnect the battery cable for 1 minute it clears the problem. Have already replaced amplifier board.
Expert:  Clifton B. replied 2 years ago.

hi my name is ***** ***** i will help with your question

Expert:  Clifton B. replied 2 years ago.

do you also have a problem with the dash cluster when this happens ??

Customer: replied 2 years ago.
No. My problem is something is causing the unit to go blank. When this happens the LCD panel goes out, the radio stops functioning. The a/c functions, but you are not able to change any settings. I have already replaced the amplifier with a new one. Same problem. If I disconnect the neg battery terminal for 1 minute it will resume working for a period of time.
Expert:  Clifton B. replied 2 years ago.

when you say amp do you mean the white box under the radio ??

Customer: replied 2 years ago.
Part #277601Y000. The problem seems to be intermittent because it will happen only two or three times during the day.
Expert:  Clifton B. replied 2 years ago.

the only other thing that can cause this is the display control unit as all the a/c and radio signals run thou that unit

Customer: replied 2 years ago.
Is this a common problem?
Expert:  Clifton B. replied 2 years ago.

not really only seen i few but very common for the amp unit to go on car without navi

Expert:  Clifton B. replied 2 years ago.

do you have any more questions ?

Expert:  Clifton B. replied 2 years ago.

if you have no more questions please rate the service before you go as this is the only way for me to get pay thanks .