How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Clifton B. Your Own Question
Clifton B.
Clifton B., ASE Master Auto Tech
Category: Nissan
Satisfied Customers: 3892
Experience:  ASE Master Certified Tech, Nissan Master Certified Tech, 12 yrs. experience in auto repair.
6166830
Type Your Nissan Question Here...
Clifton B. is online now
A new question is answered every 9 seconds

I have a 2005 Nissan Altima 2.5 and I have been working on

Customer Question

I have a 2005 Nissan Altima 2.5 and I have been working on this car for months I had to replace crank and camshaft sensors, cleaned fuel injectors, changed spark plugs, valve cover head.the car runs better but is still not 100% fixed.my cars gas mileage went from 23mpg to 18.5 mpg and when I go over 70 for more than say 20 miles when I slow down it feels like a jerk not hard but like its off and when I slow down to idle in drive it vibrates and want to kill I give it gas it doesent kill but gets up slow and after that it will stop until I drive it on interstate the mechanic sayed it might be cat or 02 sensors he said he couldent go further until that was fixed well that would cost a lot so my uncle to it off and cleaned it to see if it was clogged it wasent the precat anyway I really have no more options if you know please help also once my uncle left battery disconnected for a few hours and the mpg went to 23 mpg ran good and stayed there for a few days then startyed to drop and the problem again
Submitted: 1 year ago.
Category: Nissan
Expert:  Clifton B. replied 1 year ago.

hi my name is ***** ***** i can help you today id the service engine soon light on in the car ??

Customer: replied 1 year ago.
THANKS CLIFF ITS PO420
Expert:  Clifton B. replied 1 year ago.

ok and the cat is not broken apart correct ??

Expert:  Clifton B. replied 1 year ago.

i would start by checking the negative battery cable under the battery where it bolts to the trans the cable brake there and cause all kind of problem with the car also check all the motor mount the top one always brake

Expert:  Clifton B. replied 1 year ago.

you should also get the idle relearn do on the car to help with the idle going to low you will need a good scan tool for this so you may need to go to the shop

Expert:  Clifton B. replied 1 year ago.

check that cable and let me know

Customer: replied 1 year ago.
my uncle looked at it and said it looked okay a little clooged but not much he said would there be noticeably damage to the pre cat or would I need to know what im looking for and I just checked the ground its not loose or anything
Expert:  Clifton B. replied 1 year ago.

di you check to make sure the ground is connected to the trans it brakes right at the trans ??

Expert:  Clifton B. replied 1 year ago.

if the cat is even a little clog it will cause a problem the bottom of the cat or the hold where the top 02 sensor bolt into si a good place to check it . as far the pre cat the holes in it would be clog

Customer: replied 1 year ago.
it does
Expert:  Clifton B. replied 1 year ago.

what do you mean yes it does not sure ??

Customer: replied 1 year ago.
its connected to the transmission
Expert:  Clifton B. replied 1 year ago.

ok so get the idle relearn done and let me know if that work

Customer: replied 1 year ago.
okay could I get that done anywhere like a auto parts place or a mechanic would have to do it and would a bad cat not clogged cat could it cause that problem im having
Expert:  Clifton B. replied 1 year ago.

if the cat is not clog no it will not cause this and you need a shop for the relearn