How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jay Your Own Question
Jay
Jay, Nissan Technician
Category: Nissan
Satisfied Customers: 20225
Experience:  20+yrs experience with Nissan & Infiniti Trained & Certified.Currently still working for Dealer
10181755
Type Your Nissan Question Here...
Jay is online now
A new question is answered every 9 seconds

I have a 03 frontier base model manual transmission I was

Customer Question

I have a 03 frontier base model manual transmission I was driving it and it had a power surge the blower started blowing a lot faster and then the car died scanner has no communication wipers don't work headlights don't work cranks no start does have fuel no spark no signal to distributor tried replacing Computer with used one wipers work now that's the only difference still no communication can you help?
Submitted: 1 year ago.
Category: Nissan
Expert:  Clifton B. replied 1 year ago.

hi, this sounds like you have a bad alternator that have over charge the car and most likley blow a few fuses and some computer , first thing you should do is check all fuses also did you program the key after you replace the ecm ??

Customer: replied 1 year ago.
Have checked all fuses other then fusible links it doesn't have a chip key it it cranks it wouldn't crank if the computer didn't like something checked all relays
Expert:  Clifton B. replied 1 year ago.

the car will crank even with a bad computer

Expert:  Clifton B. replied 1 year ago.

do the condenser fan run when the key is on ??

Customer: replied 1 year ago.
No they do not run
Expert:  Clifton B. replied 1 year ago.

did you check power and ground at the ecm since you have no communication ??

Customer: replied 1 year ago.
No I did not just figured since all the grounds are good and all the fuses are good it would have power and ground
Expert:  Clifton B. replied 1 year ago.

not really

Expert:  Clifton B. replied 1 year ago.

you say you have no spark at the distributor and no power ??

Customer: replied 1 year ago.
Do you have a pin chart so I know what wires they are?
Customer: replied 1 year ago.
I have power but no signal telling it to spark
Expert:  Clifton B. replied 1 year ago.

hold on please

Expert:  Clifton B. replied 1 year ago.

at purple and white wire the volts should be between 0 to .5 when starting you need a scope to even see it

Customer: replied 1 year ago.
Are you talking at the computer? And I have one
Expert:  Clifton B. replied 1 year ago.
Expert:  Clifton B. replied 1 year ago.

ecm pin

Expert:  Clifton B. replied 1 year ago.

at the distributor please check for power and ground at the ecm

Customer: replied 1 year ago.
It would help if I had the ecm plugged all the way in runs now but the air bag light is flashing will that need to be flashed to go away or could it of messed up some of the sensors and do you think it would blow out most of the light bulbs in the car? None of the lights worked I replace the headlights now they work only those do you think that's possible?
Expert:  Jay replied 1 year ago.

Hello, my name is ***** ***** I am a new Expert here to try to help you with your issue.

The air bag light can be caused by low battery voltage. I can tell you how to try to clear that light, I would just like to know what else is not working please.