How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris(aka-Moose) Your Own Question
Chris(aka-Moose)
Chris(aka-Moose), Nissan Technician
Category: Nissan
Satisfied Customers: 615
Experience:  16 years of experience
2499435
Type Your Nissan Question Here...
Chris(aka-Moose) is online now
A new question is answered every 9 seconds

Altima: Im Jay also and work in the Canton Plant. I have a

Customer Question

Im Jay also and work in the Canton Plant. I have a 2005 2.5 Altima. Turns over, but will not crank. Changed the fuel pump and crank sensor. Sounds like it wants to crank up, but will not
Submitted: 1 year ago.
Category: Nissan
Expert:  Jay replied 1 year ago.
Hi, My name is*****'m happy to help you. During our conversation, I may be presenting you with different things to try, and ask you some Questions to get a better understand of the issue so I can answer your question properly. So stick with me to the end, and I am sure we should be able to get this issue resolved for you! Well Jay.. When you turn the key to the ON position, can you tell me if the Security light is ON Solid?
Customer: replied 1 year ago.
I do not see any security light that is on
Expert:  Jay replied 1 year ago.
Do you know if you have any codes? Also, where did you buy the Crank Sensor?
Customer: replied 1 year ago.
We attempted to pull codes several months ago with a cousult at the plant and were unable at the time. Not sure if it was my car or the consult. I bought the sensor from Auto Zone.
The car had several months prior had started easily, but with a rough idle for about 30 secs and then cleared up. It did that for months. When attempting to start the car now, it turns over great, sounds like its firing and wanting to crank, but just will not. About a month ago, it finally started one day. It ran fine. Parked it and it has not started since. ANy suggestions about getting codes? I chan check with our guys in heavy repair to take test equip home if needed. Are the OBD testers from Auto Zone wort even messing with?ThanksJay
Expert:  Jay replied 1 year ago.
Well, The first thing I will suggest is to replace that crank sensor you brought at auto zone and get one from the dealer. It's very common for after market electrical parts not to work and cause this type of condition. Especially if you had a Cam or Crank Sensor code which made you replace the sensor to begin with. Once you have replaced it with one from the dealer, return back and let me know if it starts. Sound good?
Customer: replied 1 year ago.
Will do, thank you.
Expert:  Jay replied 1 year ago.
Your welcome.. Please return and let me know how you make out.