How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 3898
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now
A new question is answered every 9 seconds

Altima: I have a 2008 Nisan Altima with 300K miles I replaced

Customer Question

I have a 2008 Nisan Altima with 300K miles I replaced the transmission 60,000 miles ago
I am experiencing no acceleration on warm days above 80 after an hour drive where the care says at speed but will accelerate the Nissan dealer does not know what the issue is but changed fluid and said they did see one code P7.. transmission control module and are now saying I need to replace transmission again. any thoughts
Submitted: 2 years ago.
Category: Nissan
Expert:  Jake replied 2 years ago.
Hi there, thanks for your question.
If this ONLY happens after long commutes when transmission temperatures are the highest, it COULD be a fluid temperature logic issue. When this happens the transmission goes into fail safe more and you cannot accelerate.
The fix for this is to install an external cooler which keeps fluid temps slightly lower and prevents the condition on long commutes.
There was actually a bulletin for this and Nissan sold the assembled kit for it with brackets and hoses for like $570.