How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 3967
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now
A new question is answered every 9 seconds

frontier: . I have a 2005 frontier 4.0 with no crank and

Customer Question

Hi. I have a 2005 frontier 4.0 with no crank and no bus. This car jad the same concern 2 years ago. Radiator was changed and trans was rebuild. Trans fluid is clean. I droped the valve body and saw little rust on valve body and few drops of coolant. Mayve the trans was not flush correctly. I replaced the valve body with a dealer part and bypasse the radiator Trans cooler with a external one. Car now starts but o/d off light is stays on. And vehicle stays in limp in mode. Is there a relearn or something need since it's a new valvebody?
Submitted: 2 years ago.
Category: Nissan
Expert:  Jake replied 2 years ago.

Hi there, thanks for your question.

no relearn or initialization is needed on these because its one assembly.

what trans codes are you getting?

Customer: replied 2 years ago.

No codes come up with generic scanner. I will borrow a solus tonight to check.

Expert:  Jake replied 2 years ago.
Thanks, ***** ***** need to access the TCM likely to see what codes present.
talk to you soon.
Customer: replied 2 years ago.

Check for dtcs on all modules with solus found no codes. Od off light still on and in limp in mode.

Expert:  Jake replied 2 years ago.
Hmm well that is certainly peculiar. you could communicate with all modules though correct? none were not communicating?
Customer: replied 2 years ago.

Found 8 modules. Data stream working on Trans module.

Expert:  Jake replied 2 years ago.
good, your speed signals were good? input and output sensors readings properly? TPS switches in the throttle corresponding with throttle?
Customer: replied 2 years ago.

Turbine speed read at ilde about engine rpm speed. Once in gear in idle goes to 0. driving it reads good same with output speed sensor. Tps sensor also reades good. Are you sure the tcm doesn't need a update or something?

Expert:  Jake replied 2 years ago.
if you replaced the valve body with TCM there is no reason to initialize it if its a new part. If you rebuilt the valve body and used the original TCM then you want to initialize the trans which simply erases the EPROM.
Expert:  Jake replied 2 years ago.
granted most people who have cross contamination issues have to REPLACE the valve body and TCM.
Expert:  Jake replied 2 years ago.
I am not familiar with the initialization procedure on any other tools then a dealer scan tool. So I am not 100% sure if you can do it or not with yours.
Customer: replied 2 years ago.

I check with the solus there is no option for relearn and stuff. I'll take it in to the dealer. Maybe the tcm need to be updated or something. thanks.

Customer: replied 2 years ago.

Or maybe parts gave me the wrong valvebody?

Expert:  Jake replied 2 years ago.

Whats the VIN and part# ?

I am guessing you got the right part but we can check.

Customer: replied 2 years ago.

Here's the Vin I have the part number at home.

1N6AD06U15C41287

Expert:  Jake replied 2 years ago.

thats not long enough. Should be 17 characters and thats 16

Customer: replied 2 years ago.

Sorry it's there is a 1 at the end.

Expert:  Jake replied 2 years ago.
31705-EA20C
Customer: replied 2 years ago.

OK I'll check it tonight

Expert:  Jake replied 2 years ago.

ok