How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chase Capicotti Your Own Question
Chase Capicotti
Chase Capicotti,
Category: Motorcycle
Satisfied Customers: 14
Experience:  Co-Owner / Service Manager at Advanced Motorcycle Performance
99103470
Type Your Motorcycle Question Here...
Chase Capicotti is online now
A new question is answered every 9 seconds

My 2012 Harley Switchback cuts out very briefly while

Customer Question

My 2012 Harley Switchback cuts out very briefly while driving. It is electrical as the dashboard goes dead. it comes on immediately again. it does not give a fault code nor does the engine warning light come on.
JA: Just to clarify, what are the exact lights you're talking about?
Customer: everything goes out briefly - the speedo goes to zero as well. no lights goes on
JA: What is the model of your '12 motorcycle?
Customer: it ia a Dyna Switchback
JA: Are you fixing your bike yourself? What have you tried so far?
Customer: I have checked the connections on the battery terminal. have taken it to dealer to check all connections. They say everything is ok
JA: Anything else you want the mechanic to know before I connect you?
Customer: It happens intermittently. sometimes 3 times in 5 miles, sometimes never in 300 miles
Submitted: 2 months ago.
Category: Motorcycle
Expert:  Chase Capicotti replied 2 months ago.

Hi there!

It definately sounds like there is a connection issue somewhere. I would first try removing your main power and ground cables, place a multimeter lead at each end and move the cable around while monitoring continuity. It is possible that there is some corrosion or damage inside the insulation of the wires and the vibrations could be making and breaking continuity.

Customer: replied 2 months ago.
Appreciate - I shall get hold of a multimeter and test it. Where is the ground cable attached to the frame/engine? would it help in any way if I add a second ground cable? Could the main fuse be the culprit? I will replace that as well.
Expert:  Chase Capicotti replied 2 months ago.

It should be somewhere around the primary or starter. I would not recommend adding a new ground. Be sure all of you engine mount bolts are tight as well. The main fuse is a great area to check, I would replace and check for corrosion.

Customer: replied 2 months ago.
I have checked and tightened everywhere. Used elecric contact spray to treat all connections. Removed instrument cluster and checked connections on ignition switch. checked for loose wires. Removed battery and cheched for possible clamped wire behind it.Re-tightened and torqued battery connections. Took it for a ride. Problem not solved. ??