How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kenny O. Your Own Question
Kenny O.
Kenny O., Motorcycle, ATV, Mules, Side by Side's Product Specialist. All Brands
Category: Motorcycle
Satisfied Customers: 995
Experience:  Worked for Kawasaki Motors as a Product Support Specialist (Factory Support) for 24 years
30381042
Type Your Motorcycle Question Here...
Kenny O. is online now
A new question is answered every 9 seconds

2004 Yamaha r1 rough idle and when I rev it and hold it at

Customer Question

2004 Yamaha r1 rough idle and when I rev it and hold it at a certain rpm it rpm fluctuates and it does the same thing at idle. I've changed plugs plug wires airfilter and I've even ran sea foam through it. What's wrong with my bike
Submitted: 1 year ago.
Category: Motorcycle
Customer: replied 1 year ago.
If I just rev it up its fine but when I hold the throttle it starts missing. The bike has power but when I'm riding and I maintain a speed i can still hear it
Expert:  Kenny O. replied 1 year ago.
Hi James, my name is***** have a few questions before we get started.How many miles are currently on your bike ?Has this unit been sitting for any amount of time, if so how long ?If you had been sitting was the fuel stabilized ?Any modifications (exhaust and or fuel and or ignition) ? if so please list all mods ?Valve adjustment or checked last time ?Thanks
Customer: replied 1 year ago.
I just recently bought the bike used. It didn't have an exhaust and I put yoshi trs on it other than that there's no mods that I kno of
Expert:  Kenny O. replied 1 year ago.
OK, please answer ALL the questions I asked !Thanks
Customer: replied 1 year ago.
14k miles. I don't know if it's been sitting I don't know if valves have been checked and the only mod is the yoshi exhaust
Expert:  Kenny O. replied 1 year ago.
Thanks James, when we cant physically touch what we are trying to diagnose it make it much easier the more information we can gather.So obviously you have not done anything here, the one thing that concerns me is the amount of mileage and the age of the bike, so that tells me that this unit has sat more then ridden in a year, I don't think that you have anything serious going on other then maybe a spark plug issue and possibly a dirty injector or two ? So here is what I would recommend first, find a Auto Parts store (O'reilly's) and in the isle were they have all the fuel treatment additives, you need get a bottle of Techron, its made by Chevron (I saw that you tried Seafoam) It not an additive that I ever had good luck with, Techron is labeled under the manufactures also, it works really well if you have an injector that's clogged, it also works Great to de-carbon the inside the engine, I would run a high concentrate (don't worry it wont hurt anything)After running a bottle through a tank of fuel and you still have an idling issue then I would change the spark plugs out, these plugs are about $30 for a set of four, I would suggest first trying the Techron and then the plugs, the only draw back about changing the spark plugs out is they are not the easiest to get to, it about a couple of hours.Yamaha requires the first valve adjustment at 26,600 so you are OK there, honestly it sounds like a fouled spark plug, but try the additive that I recommended first and then plugs if it doesn't get better.Let me know of you have any questions.Thanks JamesKenny
Customer: replied 1 year ago.
I've already changed plugs, coils and harness
Expert:  Kenny O. replied 1 year ago.
I think you still have an injector issue, you have no fault codes, and knowing these from experience (my R6) has the same issues, I run a bottle through (especially when it sits) amount every 3000 miles. You can also have a problem with the throttle not being in sync, but that is usually a different symptom.When you say you changed the "harness" do you mean the complete main harness ?
Customer: replied 1 year ago.
Yes
Expert:  Kenny O. replied 1 year ago.
So you changed the complete wiring harness ? whos direction was that under and what was the reasoning for that ? was the old one damaged ?
Customer: replied 1 year ago.
Yep the old one had frayed and exposed wires so I changed them too. I'm thinking it could be the tps I'm gone clean it then if that doesn't work I'll buy a new one. I ran a diagnostics on it and with the throttle closed it was 15 and with it all the way open it was 95. I don't think that inside the tolerances I think it needs to be replaced. Last option i kno of besides checking for vacuum leaks
Expert:  Kenny O. replied 1 year ago.
Checking for vacuum leaks is fairly easy, get some contact cleaner and spray around the throttle bodies and if the idle fluctuates when spraying then likely you do, did you move the TPS at all ?
Customer: replied 1 year ago.
No I haven't touched it. What's contact cleaner
Expert:  Kenny O. replied 1 year ago.
Technicians use that for cleaning parts off, brake clean, WD40 anything that will burn, so if you have a vacuum leak it will pull what ever you are spraying and then you'll notice a change in the idle, it will usually rise up.
Customer: replied 1 year ago.
Ok thanks
Expert:  Kenny O. replied 1 year ago.
Welcome !Thanks

Related Motorcycle Questions