How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Mitsubishi Mechanic
Category: Mitsubishi
Satisfied Customers: 25677
Experience:  25 years experience on all makes and models. Nissan and Subaru factory trained.
2921078
Type Your Mitsubishi Question Here...
Mike V. is online now
A new question is answered every 9 seconds

Getting po340 code. changed crack shaft

Customer Question

getting po340 code. changed crack shaft sensor,pcm,immobilzer,key.still wont start,still getting code.is there afuse or relay?
JA: How many miles are on the car? Has the car been starting normally?
Customer: 120k,died while driving the other day. before that ,normal
JA: What is the model/year of your Mitsubishi?
Customer: 2003 mitsubishi galant
JA: Are you fixing your Galant yourself? What have you tried so far?
Customer: yes. crankshaft sensor, pcm,immobilzer, key, replaced
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 1 month ago.
Category: Mitsubishi
Expert:  Mike V. replied 1 month ago.

Thank you for your question!
My name is ***** ***** give me a moment to review your question and type my reply. Thanks

Expert:  Mike V. replied 1 month ago.

Which engine do you have in this?

Customer: replied 1 month ago.
2.4
Expert:  Mike V. replied 1 month ago.

Ok, i see you replaced the crank sensor, but the code is for the cam sensor. Have you replaced that as well?

Customer: replied 1 month ago.
Expert:  Mike V. replied 1 month ago.

Have you checked for spark and fuel pressure?

Customer: replied 1 month ago.
Is there a fuse or a relay to be replaced
Expert:  Mike V. replied 1 month ago.

I am looking, do you have a test light so you can check some fuses for power for me?
Also, have you checked it for spark or not?

Customer: replied 1 month ago.
both spark and fuel pressure are fine
Expert:  Mike V. replied 1 month ago.

Ok

Try this, spray some carb cleaner or starting fluid directly into the throttle and see if it will run for a few seconds. If it's got spark then it should run off of this for a few seconds.

It can have fuel pressure but no injector pulse and that can cause this.

If it's got spark and fuel pressure, it's not a fuse issue.

Please try this and let me know.

Customer: replied 1 month ago.
Sounds like it wants to start but nothing. Which fuses should be checked
Expert:  Mike V. replied 1 month ago.

Like I said, if you have spark and fuel there isn't a problem with the fuses. The computer is doing it's job and so are the fuses. It sounds like the timing belt has jumped time. This will give you a code for the cam sensor and if it's only off a couple of teeth the car will try to start. You can confirm this with a compression test, or check and make sure all the alignment marks line up.