How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Technician
Category: Mercury
Satisfied Customers: 7121
Experience:  17 years Shop Owner /Technician. 27 years experience,
29331485
Type Your Mercury Question Here...
Greg is online now
A new question is answered every 9 seconds

A problem that seems to be pretty common according to forums

Customer Question

Hi! A problem that seems to be pretty common according to forums but my mechanic is confused. Cant find anything wrong. 1997 village GS with only 69K miles. Well maintained. Ran like butter then engine light comes on and brought it in. Mechanic said ran rough for a few minutes then fine. Reset engine light so I could try to pass emissions. After 100 miles car ran rough a minute, light flashed and then stayed on. 100 miles later went off. Ran great. 100-200 later light back on and running very rough about half the time. Light it isnt getting gas. Hesitated then took off as I was going up a hill. But also in city and on freeway. Intermittent but worse. ??
JA: Have you metered out the ignition system? What confuses you?
Customer: He recommended an expensive fix. Wasnt sure but thought "probably" the problem. Only thing left to check he said. But local auto parts shop ran diagnostic code and it said something about spark plugs. Mechanic said plugs fine. Hmmmm. I keep seeing posts about distributor being issue on these vand
JA: Are you fixing your GS yourself? What have you tried so far?
Customer: Metered out ignition system? Tested you mean? The ran every possible diagnostic at mechanic. Checked everything
JA: Anything else you want the mechanic to know before I connect you?
Customer: Not really. Bought four weeks ago. Ran amazingly smooth till now. I had a 95 villager for 17 years with same problem. It was a loose wire.
Submitted: 12 months ago.
Category: Mercury
Expert:  Greg replied 12 months ago.

Hi, I'm Greg (Indy-Tech).
Welcome to JustAnswer. I'm reviewing your question now, and will post back with your reply ASAP.
Rgds Greg.

Expert:  Greg replied 12 months ago.

Hi Karin .

Which engine do you have fitted .

If not sure give me your first 10 digits of the VIN

Rgds Greg

Customer: replied 12 months ago.
V6 3 liter nissan
Customer: replied 12 months ago.
Mechanic wants to replace fuel injectors. But isnt sure. I have read distributor caps on this vehicle commonly cause the problem by little flakes that break off and clog
Customer: replied 12 months ago.
Hello? I should mention they spent days checking it out. Could see nothing wrong. Ran rough for them a couple minutes then fine. It is two weeks later and now I have rough running off and on 50 percent of the time. Getting worse. They ran diagnostics. It DID pass emissions. Light went out for a time. Cameback
Customer: replied 12 months ago.
Never mind. Forget it.
Expert:  Greg replied 12 months ago.

Hi karin sorry just had to pop out and take the kids to school .

For the mechanic to be sure tell him to swap over number 1 for number 3 injector test drive and recheck for codes .

now if the injector is the problem the malfunction code will change to P0303 and nor P0301. this confirms bad injector .

If code stays the same P0301 then the injector was not the problem .

Fuel pressure should first be check before doing the injector swap.as low fuel pressure can cause you this issue .

Also as you may have read on line the Distributor are a big issue in failing have your mechanic check the distributor for shaft bearing

failure , very typical issue in causing misfire .

Please check this then please get back to me .

Rgds Greg

Customer: replied 12 months ago.
Ok. It would seem to me they did none of these checks. They said the found nothing wrong other than rough running. But said it is probably a bad injector because they ruled everything else out. Had they tested injectors they would know for sure. Right? Also... I called them this morning and told them I found a forum about same problem and after many people had thousands of dollars of other things replaced, in the end... more than 70 percent of the time, it was the distributor that ultimately cured the problem. Wishing they had figured it out sooner. He replied "I dont think you even HAVE a distributor in this car." Oh boy. Yes, I verified it. Villagers from 1993 - 2002 have distributors. They arent easy to find, but they are there and commonly cause the problem. If the mechanic working on my car is not aware of a distributor cap and doesnt understand the vehicle... I have a problem. He wants to replace all fuel injectors. Very expensive and most likely wont fix
Customer: replied 12 months ago.
Also to note: it doesnt misfire or stop running. It sputters and loses some power, not all though, sometimes. Kind of hobbling around. Slows down, minor shake felt in the wheel, runs crappy and giving gas the car doesnt zoom like usual but struggles to accelerate. And other times it has great pick up/fast acceleration and runs exceptionally smooth. It doesnt happen just at idle or in certain conditions. Happens at higher speeds, city driving, and especially when going up hill (hesitates after giving it gas the then gets gas and lurches forward).
Expert:  Greg replied 12 months ago.

NOT injectors Karin .

Get that car of your's out of there and into another well know repair shop.

looks like they have no idea whats up with your car and just guessing .no trouble shooting what so ever .

Sounds very much like the distributor from what you just explained,but little test should be done .

Find another repair shop karin before you get money pitted .

Kind regards Greg