How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Mercury Technician
Category: Mercury
Satisfied Customers: 1957
Experience:  16 years experience with Mercury
2499435
Type Your Mercury Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

Air conditioning system appears to be OK. Freon level is

Customer Question

Air conditioning system appears to be OK. Freon level is correct and there is no evidence of a leak. The clutch is cycling in the proper manner. Except the controls that are built into the bottom frame of the Radio unit are not functioning as expected. In Example: The button (second from the left of Maximum AC), Normal AC. That should direct the flow of cold air through the registers on the dash board into the passenger compartment appears to be none functional. All the cold air is coming through, either from the Floor vents or Floor and Defrost vents. Interestingly, this will change while I am driving. Having the Normal AC button activated! As I reduce my speed, (coming to a stop) a minimal volume of air, from the registers, can be experienced. The same while the engine is idling. However, as I increase my speed this light volume of air disappears and the full volume of cold air would be coming through the Defrost and the Floor vents. Total disregard to the normal AC button that was activated. At this point I am uncertain whether it is the Normal AC button, or may be the vacuum activated solenoids that are controlling the buffers?
Your advise would be greatly appreciated!
Sincerely: E. Nagy ***@******.***
Submitted: 11 months ago.
Category: Mercury
Expert:  kalamykid replied 11 months ago.

What is the year and model of your car please?