How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4951
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

My 2003 G500 W463 started dying while driving.Error code for

Customer Question

My 2003 G500 W463 started dying while driving.Error code for a faulty crankshaft position sensor so replaced it. Cleaned MAF too. Now gas pedal is dead. will idle but no acceleration. Error code P0120 for TPS so replaced it. Still no acceleration. Tried to reset ECU and TCU. Nothing.
Submitted: 1 month ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 month ago.

Hello, my name is***** and i will do my best to assist you.I am going over your story now and will reply back soon with some info,thanks!

Expert:  Lou P. master tech replied 1 month ago.

I'm sure we can get this fixed up , when you did the crank sensor you didn't unplug the throttle body for any reason did you ? Also what kind of scanner are you using ?

Expert:  Lou P. master tech replied 1 month ago.

P0120 can actually be a few different things . If this happened after you replaced the sensor then I would worry that another wire got damaged or a connection is unplugged .