How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gunvir Singh Your Own Question
Gunvir Singh
Gunvir Singh,
Category: Mercedes
Satisfied Customers: 1644
Experience:  Master Tech at Kennesaw Auto Tech
97664209
Type Your Mercedes Question Here...
Gunvir Singh is online now
A new question is answered every 9 seconds

I have a 2012 GL450. Rear suspension will randomly lower.

Customer Question

I have a 2012 GL450. Rear suspension will randomly lower. Raises back up if I put in park, kill & restart the engine. There is no pattern to this which leads me to believe it isn't a strut or air spring but possibly the ride height sensor. Can you give me a diagram of the location of the rear sensor? Thanks!
JA: Okay, I'll connect you to the mechanic to help find that for your Mercedes. Before I do, is there anything else you want him to know?
Customer: We keep having issues with the rear hatch no opening. It will close automatically, but has to be opened manually. And it makes a knocking sound for about 2-3 seconds at each start, then clears up and runs fine.
Submitted: 1 month ago.
Category: Mercedes
Expert:  Gunvir Singh replied 1 month ago.

Hello, let review your request. Please stand by.

Expert:  Gunvir Singh replied 1 month ago.

Is it just one side that goes down or both sides rear?

Customer: replied 1 month ago.
Both sides. Did you not get my other 2 issues as well?
Expert:  Gunvir Singh replied 1 month ago.

Yes, i did. Attached illustrations show the location of both rear ride height sensors. A compatible scan tool will be needed to test the sensors. I will still recommend to take a visual inspection to make sure the connectors are tight and sensor in place.

Do you hear any click or tick noise from the rear door hatch when it fails to open?

Customer: replied 1 month ago.
No sound.
Expert:  Gunvir Singh replied 1 month ago.

That ususlly points towards a faulty actuator. Very common on these vehicles. Need to remove the electronic connector and check if signal present to the actuator from the door hatch open switch.

Customer: replied 1 month ago.
Gotcha! Now what about the valve clatter sound on starts?
Expert:  Gunvir Singh replied 1 month ago.

You hear that every time you start or after it sits for a while?

Customer: replied 1 month ago.
When it sits for a minute. Not every single time.
Expert:  Gunvir Singh replied 1 month ago.

Roughly how many miles are on the engine ?

Customer: replied 1 month ago.
61K
Expert:  Gunvir Singh replied 1 month ago.

And roughly how long ogo was the engine oil changed?

Customer: replied 1 month ago.
Less than 500 miles ago
Expert:  Gunvir Singh replied 1 month ago.

Was the noise present before?

Customer: replied 1 month ago.
Customer: replied 1 month ago.
May have started after previous service. Can't recall
Customer: replied 1 month ago.
Isles rough like a misfire for maybe 2 seconds then clears up perfectly
Expert:  Gunvir Singh replied 1 month ago.

The symptom usually occurs due to lack of lubrication to the lifters, once you start the engine and builds up oil pressure the noise is gone. Worn lifters are the usual culprit but since the vehicle has only 60K miles on it, i will recommend to check if correct viscosity oil was used and oil filter is good.

Customer: replied 1 month ago.
What viscosity is recommended? Service was done by certified Mercedes mechanic. Can't imagine they used wrong oil or didn't replace filter. I certainly paid enough to be confident in that.....
Expert:  Gunvir Singh replied 1 month ago.

You can use 0W40 or 5W40. If the fluid and filter is goog, you can also add an oil stabilizer treatment before starting actual engine repairs.

Customer: replied 1 month ago.
But would it shake like a misfire if it were just valve train not getting proper lunrication? And if it were the wrong weight oil, wouldn't it continue to do the same at idle and not clear up?
Expert:  Gunvir Singh replied 1 month ago.

THis vehicle has hydraulic lifters. They require proper oil pressure to work under specifications.

Customer: replied 1 month ago.
Let's assume the correct oil was used. Now what? What is the factory engine warranty?
Expert:  Gunvir Singh replied 1 month ago.

Unless you have an extended warranty, these vehicles come with 4 year/50,000 miles warranty.

Customer: replied 1 month ago.
But doesn't the engine & valve train have a longer warranty?
Expert:  Gunvir Singh replied 1 month ago.

Other than some emission related components, rest of the vehicle comes under 4 year/50K warranty.

Customer: replied 1 month ago.
No other possible cause for misfire on start?
Expert:  Gunvir Singh replied 1 month ago.

This will be the first place to start. There is a possibility of a leaking fuel injector or dirty oil screen. It cant be an electronic failure as a fault light would have been triggered.

Expert:  Gunvir Singh replied 1 month ago.

Do you have any other questions?

Expert:  Gunvir Singh replied 1 month ago.

Please read this:

Understand it's not one answer and done. We can communicate back and forth many times.

1. I am an independent auto mechanic and do not work at or for Just Answer.

2. When you're pleased or happy with my assistance or efforts to help you, at the top of the screen please rate me .

3. I only get credit for my work from your question value deposit when you rate me on this screen. Rating does not close the post and you're more than welcome to follow up.

Thanks for using Just Answer