How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Technician
Category: Mercedes
Satisfied Customers: 7131
Experience:  17 years Shop Owner /Technician. 27 years experience,
29331485
Type Your Mercedes Question Here...
Greg is online now
A new question is answered every 9 seconds

I own a Smart 450 CDI 2006 and It does'nt start since I have

Customer Question

I own a Smart 450 CDI 2006 and It does'nt start since I have replace the clutch lever... I have a aukt code from the OBDII,
JA: How many miles are on the clutch? Has it been slipping or sticking?
Customer: There is 206 000 KM the code reading is P2256 ?
JA: What is the model of your '06 Mercedes?
Customer: 450 CDI
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Yes I am a retired car mechanic I had work a lot on VW diesel engine
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 2 months ago.
Category: Mercedes
Customer: replied 2 months ago.
I also have fault code C1340
Expert:  Greg replied 2 months ago.

Hi, I'm Greg (Indy-Tech).
Welcome to JustAnswer. I'm reviewing your question now, and will post back with your reply ASAP.
Rgds Greg.

Customer: replied 2 months ago.
Hi Greg,
The actuator push rod went through (puncture) the clutch lever. The engine has started twice after the repair, but stalls after 3 seconds and never started again. The primary fuel pump works O.K. I have erased the stored code... and the engine still refuse to start. The voltage at the battery is 12.86 V.Thanks,Luc
Expert:  Greg replied 2 months ago.

Hi luc .

Is the engine cranking over and not starting

or nothing at all.

Greg

Customer: replied 2 months ago.
The engine is cranking over but do not start.
Expert:  Greg replied 2 months ago.

Okay clear codes then crank engine for 10 seconds then wait 5 seconds and then crak again for 10 secods ,do this three times then recheck for codes .

Greg

Customer: replied 2 months ago.
No code. I have removed the transmission to check the flywheel positioning. I am quiet sure that I have aligned it according to the dowel pin... but as I have said before the engine was running before the clutch lever and the clutch replacement. Every electrical wiring and connection were checked out. The primary fuel pump seems O.K. So... what else could it be ? I have to clear this aspect out of my mind.
Thank you Greg, I know that it is very hard to help at distance. You do not know what kind of knowlage I have, you just rely on
my report to you.Luc
Expert:  Greg replied 2 months ago.

Okay try the following ,

Remove the air intake hose at the throttle body .

Soak a clean rag in petrol .

wring out the rag so its not dripping petrol and then hold

the rag over the intake and crank over the engine ,the fumes from the rag will make the engine start ,

as soon as it starts remove the rag .

If she starts then stalls check fuel delivery system.

Greg

Customer: replied 2 months ago.
Dear Greg,It is a Diesel... 450 CDI, there is no throtlle body. What means the P2256 for a Diesl (engine code) tha was stored. After code earasing, it never show again. I think that the engine has to run to register code ?
I have removed the flywheel assembly because I had a doubt... but everything was perfectly aligned.
I am about to finish the reassembly a try again. I will have a closer look after the electrical wiring and sensors.
Thanks again,Luc
Expert:  Greg replied 2 months ago.

Luc i know its a diesel ,intake to the intake manifold is a similar TB .

But on the intake hold the rag.

Greg

Customer: replied 2 months ago.
Dear Greg,
Ihave found my problem... it was a wire that goes to the shutoff valve on the injection pump. It was damaged in the envelope cause by a little kink on it. Hard to see at first. This is when I check the continuity from all the electrical connection to the ECU, then BINGO... the engine come to life. You were partially right to make me look this side.
Again thank you for your help... sometime talking to another mechanic helps for the moral.Luc from Montreal
P.S. maybe I could soud funny sometime, I made my english speaking friends laugh of me. I'm a french canadian,
Expert:  Greg replied 2 months ago.

Hi Luc .

Great find well done .

Don't worry about it, have family living in Montreal, just sent my daughter to Montreal for 41 days to be with her Aunty

they all speak french except me :-(.

Rgds Greg