How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 54028
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

Ml350 2010 blower fan not working and not getting main power

Customer Question

ml350 2010 blower fan not working and not getting main power supply but can't find fues
JA: Most vehicles have two fuse panels. Do you know what they look like?
Customer: yes but I have no blower fues in them
JA: Are you fixing your ML350 yourself? What have you tried so far?
Customer: checked main power supply to blower motor and has no positive supply only started to play up after the battery got replaced
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 9 months ago.
Category: Mercedes
Expert:  Marty replied 9 months ago.

Hi, there are some wires in the fuse box next to the battery that are easily knocked loose when installing the battery. Recheck the wires to the fuse box in the battery compartment. I think you will find your problem there. I've attached a picture below.

Let me know how you make out.

Marty

Expert:  Marty replied 9 months ago.

Just checking in. Did you receive my answer?