How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53979
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

Radio turns on, it no sound from speakers. Antenna not

Customer Question

Radio turns on, it no sound from speakers. Antenna not working either
JA: Is this an aftermarket stereo, or did it come with the car?
Customer: Original becker. 89 560sl
JA: Are you fixing your 560SL yourself? What have you tried so far?
Customer: Pulled head unit out to make sure connections were OK. Checked fuses
JA: What is the make/model of your car?
Customer: 89 560SL
JA: Anything else you want the mechanic to know before I connect you?
Customer: Don't think so
Submitted: 10 months ago.
Category: Mercedes
Expert:  Marty replied 10 months ago.

Hi, my name is***** is also a fuse located in the back of the radio. Make sure that fuse is good. Also replace fuse #1 and #12 in the fuse box. Even if the fuses look good they can still be making a poor connection. If all fuses are good and if the wires from the radio to the speakers are connected your problem is either a bad radio or two bad speakers.

Let me know what you find out.

Marty