How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Mercedes
Satisfied Customers: 3939
Experience:  Owner at Carolina Auto Service & Sales , 20 years experience in Foreign & Domestic vehicles
45790705
Type Your Mercedes Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

I have a 07 C230. i have read so much im lost. the car has

Customer Question

I have a 07 C230. i have read so much im lost. the car has 150k on it. It is stuck in 1st gear. reverse works and 1st gear only. It will not shift to 2nd etc. Also when putting it in gear it has a hard jerk. i have read that it could be several things from 13 pin connector to a whole trans overhaul. te codes i am getting are P0170, P0073, P00173 and P2768. I took apart the maf and cleaned it and throttle body. Motor sounds good also replaced filter (air) I noticed on the passenger side on the back of valve cover there is a plate and it is leaking oil dripping on to exhaust. do you think it could be the problem of leaking into the 13 pin connector causing it to throw these codes? (2768)
JA: How many miles are on the car? Have you been burning oil lately?
Customer: 150k no burning
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: i explain already
JA: Anything else you think the mechanic should know?
Customer: no
Submitted: 1 year ago.
Category: Mercedes
Expert:  Chad Farhat replied 1 year ago.

i, I'm Chad ,Welcome To JustAnswer, I'm reviewing your question and I will be be posting a replay ASAP

Customer: replied 1 year ago.
ok im waiting
Expert:  Chad Farhat replied 1 year ago.

The P0073 is your ambient temp sensor , so is not related

The P0170 & P0173 are oxygen sensors, or mass air flow or fuel injectors test needs to be run to know on this , most likely at that mileage the O2 sensors will require changing if you have not already ,but these are engine codes .

The P2768 , is A Fault in the trans module or (EGS) conytrol unit .or the connector to it

did the transmission fault stuck in 1st gear happened suddenly or you had trsan slippage and then it completely stopped & stuck in first ?

please let me know

Thanks

Chad

Customer: replied 1 year ago.
i just purchased car a week ago current owner said it would only drive 20 mph and he is correct. The c/s button would not switch i took it apart and it looks to be ok. there are no trans leaks that i can find. When you put the car in D it has a hard jerk and when you put in reverse. you can not manually shift it as well (-D +D)
Expert:  Chad Farhat replied 1 year ago.

i sent you location of the trans module , check the connectors on it for evidence of water intrusion or damage pins

and you need a scanner to communicate with it to see if the module is bad , if neither is bad , then it will be internally in transmission

Customer: replied 1 year ago.
i downloaded them will my ob2 scanner work? What about the oil leak i mentioned?
Expert:  Chad Farhat replied 1 year ago.

the valve cover gasket leak , will need replacement or it will keep dripping on exhaust and you see smoke come out engine area or underneath car

and if you drive it with a leak, you need to keep checking engine oil

but the oil leak will not effect the the stuck in gear situation

Customer: replied 1 year ago.
ok i understand that. but i dont believe its valve cover it looks like a plate om the back of block with a hose running to the throttle body. not sure what the correct name is? and will the ob2 scanner work with reading the module?
Expert:  Chad Farhat replied 1 year ago.

i m not sure be hard for me since i m not looking at it , as long it is not the rear main seal the one bewteen engine and trans , in that area should not be that bad

if you only have a code reader then no, what you need is a Star Software used for Mercedes or equivalent scanners, usually these scanners are $1000 or more that has the capability to not just read codes , but command and activate solenoids, run test on module outputs etc...

Customer: replied 1 year ago.
This is looking from underneath car passenger side. And without a code reader theres no point in taking it apart.
Expert:  Chad Farhat replied 1 year ago.

I think it is to high for a rear main seal from what you showing me , but it could be in several places from the heads up , it is hard tell from the picture with out clearing few thing out of the way first

Customer: replied 1 year ago.
ok well thats the only way to see it with the leak from the bottom. its deffintly not the rear main seal because its attached to the back of the block on the valve cover. It has a breather hose that runs to the mas flow.however it is blowing oil down the connnector wires thus was wondering if this could cause a wick effect?
Expert:  Chad Farhat replied 1 year ago.

if it is leaking oil down the harness , if that oil goes all the way to the transmission connector pull it out and look at for evidence of oil for sure , since you just told me that , that could be the problem with the trans code

Customer: replied 1 year ago.
This is the location from the top. Where is trans connector located?
Expert:  Chad Farhat replied 1 year ago.

take off # ***** and # ***** is actually a part you can buy and change

Expert:  Chad Farhat replied 1 year ago.

after taking off # ***** you take off # ***** bolt and then you take off # ***** ,

Customer: replied 1 year ago.
ok am i going to have to drain the fluid and take the trans pan off to get to it? did you get my other pic about oil?
Expert:  Chad Farhat replied 1 year ago.

in that area you head gasket , valve cover , there oil level sensor but it kind towards the bottom not close up.I cant tell you on this one and be accurate

Expert:  Chad Farhat replied 1 year ago.

Please let me know if you need anything else on this issue

Hope I was Helpful to you

A Positive Rating is Much Appreciated

This Post will stay open for you to come back and ask me any follow up questions you may have on this issue even after you rate me

Chad Farhat
ASE Certified Technician

Customer: replied 1 year ago.
Picture pretty self explanatory if you know mercedes motor. But ok thanks for the diagrams and my last question was do i need to drain trans and remove pan to get to 13 pin connector?
Expert:  Chad Farhat replied 1 year ago.

no , you dont have to , if you take the heat shield off and drop the transmission down a Little bit , take trans mount off & use a jack stand , you should be able to access it.

Customer: replied 1 year ago.
Ok ill report back and let you know.
Expert:  Chad Farhat replied 1 year ago.

ok sounds good