How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4498
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

2008 Ml320 cdi No sound from audio.

Customer Question

2008 Ml320 cdi No sound from audio.
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.
Hello. When you press the SAT button does the radio say no sat radio ?
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Provide Diagrams, Manuals, or Instructions + Help via Email or Text Message + Local Mechanic Recommendations. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Lou P. master tech replied 1 year ago.
I would gladly offer a phone call I must ask where you are located and you do speak English correct lol ??
Customer: replied 1 year ago.
No sat radio
Expert:  Lou P. master tech replied 1 year ago.
Ok pull up the folding left back seat. The sat radio module is under there , there may be a module or two on top of it. You need to unplug the module and reconnect it.
Expert:  Lou P. master tech replied 1 year ago.
Just to confirm you did have sat radio installed right ? It may not had been active subscription but you did have it correct ?
Customer: replied 1 year ago.
First of all cd player sign will not come on unit may be busy as it was jammed.I by pass with fiber optic jumper then i pulled rear seat behind there are total 3 unit 2 of them with fiber optic cable i unplugged fiber optic and plugged in no sound
Expert:  Lou P. master tech replied 1 year ago.
No you need to disconnect the entire module to reset it
Expert:  Lou P. master tech replied 1 year ago.
Unplugging the fiber optic does nothing.
Customer: replied 1 year ago.
one of them is sat radio
Customer: replied 1 year ago.
ok i try that
Expert:  Lou P. master tech replied 1 year ago.
Ok let me know
Customer: replied 1 year ago.
no change
Expert:  Lou P. master tech replied 1 year ago.
Ok you need to shut the radio off and back in after disconnecting to restart the fiber optics
Customer: replied 1 year ago.
how many audio unit are in car and where are they located.Like one main on dash board ,cd changer in glove box two unit under rear seat behind driver,one unit with sub speaker in on side wall in trunk.where is amplifier?
Customer: replied 1 year ago.
Hello are you there
Customer: replied 1 year ago.
Is there any thing under driver seat? My understanding is when you turn on system you should flashing light from fiber optic and also from unit am i correct?
Expert:  Lou P. master tech replied 1 year ago.
Ok yes every time you turn the radio on the unit will flash a red light so you need to check each unit for a flash. You have the radio , the sat module and the amplifier under the drivers seat and the tele aid also under there if equipped.
Expert:  Lou P. master tech replied 1 year ago.
by under the seat I mean you have to remove the seat and carpet to access under the paneling
Expert:  Lou P. master tech replied 1 year ago.
If you give me some time I will get you pictures of all the locations
Customer: replied 1 year ago.
tele aid has sound but nothing else,So two unit under back seat i do not get flashing light on both of them(mean unit and also from fiber optic)
Customer: replied 1 year ago.
If one of unit is not passing fiber optic signal is that mean fiber need repair or unit need to replaced.
Customer: replied 1 year ago.
hello
Expert:  Lou P. master tech replied 1 year ago.
Ok that is Not likely to have more than one module faulty.
Expert:  Lou P. master tech replied 1 year ago.
The cables just pass between all the modules. The modules will only flash lights when the radio is first turned on. So each time you need to turn the radio off and back on. Also if the fiber optics are unplugged you need to make sure the power wires are still connected.
Customer: replied 1 year ago.
Hello ,
So do you have any information what most likely is wrong?