How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4794
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

2012 ClS 550 Airmatic problem. When car is started pump

Customer Question

2012 ClS 550 Airmatic problem. When car is started pump turns on for 5 sec then off then on 5 sec then off until car is restarted . I scan the car with MaxiSys scanner . I got code C156784 / C156984 ( Left and right front Vehicle level is outside the tolerance. the signal below the permissible. limit value .
C155664 ( the compressed air sensor for system pressure has malfunction . there is an implausible signal )
C156c00 ( the compressed air supply is not leaktight )
car in slammed to the ground on all corners
I replaced airmatic pump due to low pressure and noise
I replaced pump Relay
I checked for Strut leaks (none )
I cheked compressed air tank for leaks (none)
Please advise and HEEEELLLLPPPP Please !!!
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.
Hello. I can help with this. It may take a little time so please be patient. Let's start at the compressor. Did this issue happen before or after replacing the pump ? Does your scanner show the values of the airmatic system? Can you read the pressure sensor values ?
Customer: replied 1 year ago.
i will check if scanner shows values
Expert:  Lou P. master tech replied 1 year ago.

ok, if not its not a HUGE deal but would be helpful to see what the module is seeing. also the intake pipe needs to be free and clear, its the black pipe that comes off the side of the compressor

Customer: replied 1 year ago.
I'm not at car yet . But I did check inlet pipe and filter to pump (not blocked )
Expert:  Lou P. master tech replied 1 year ago.

OK, so next step would be to see what the pressure sensor reads as well as making sure the pressure sensor plug and the motor plug is not burnt or have poor connections.

Customer: replied 1 year ago.
I'm at car ready for next step
Expert:  Lou P. master tech replied 1 year ago.

oh man sorry for the delay, ok so what can you read with the scanner?

Customer: replied 1 year ago.
Codes 556coo . 556784 . 556984. 555664
Customer: replied 1 year ago.
That was ELC -Electronic Level Control
Customer: replied 1 year ago.
ADS codes . c156784.c156984 . c155664 C156Coo
Expert:  Lou P. master tech replied 1 year ago.

ok let me check them, sometimes its super hard to get code info without the scan tool, they keep all that info in the scan tool.

Expert:  Lou P. master tech replied 1 year ago.

haha,. and go figure, today our startekinfo is down. :(

ok so can you activate the compressor with the scan tool?

Customer: replied 1 year ago.
Expert:  Lou P. master tech replied 1 year ago.

ok, so can you manipulate the ride height with the scan tool?

Expert:  Lou P. master tech replied 1 year ago.

what does the pressure sensor show when activating the compressor?

Customer: replied 1 year ago.
Value on left front stays at 31.3 bar with compressor on or off . I can not activate compressor from scanner . I can only start and stop car to activate
Expert:  Lou P. master tech replied 1 year ago.

ok , so do you know how to jump the terminals of the relay to get the compressor to work? terminals 87-30?

Customer: replied 1 year ago.
I do I thought you wanted it from scanner only . No problem sand bye
Expert:  Lou P. master tech replied 1 year ago.

Well if you cant activate if from the scanner then we need to jump the relay and watch the pressures and see if they move, cause you may just have a bad new compressor, where did you buy it from?

Customer: replied 1 year ago.
Arnott . I did check with direct power . I'm fustrated lost not to have my star scanner . Can you verifie pump relay location . I replaced green relay under hood as in photo
Expert:  Lou P. master tech replied 1 year ago.

that is not right, it shows to me to be in the trunk on the left side next to the storage tank on a W218 which is what your cls is.

Customer: replied 1 year ago.
Nothing from relay no power to relay where is relay fuse location ? I thank you for your patience I am willing to pay extra to get this resolved
Expert:  Lou P. master tech replied 1 year ago.

no problem i thank you for your patience my computer crashed earlier so now i am back at it. so sorry for the delay.

Expert:  Lou P. master tech replied 1 year ago.

i need to know if your model has the eco start stop function, there are 2 different fuse locations. its either fuse 160 or 162 in the prefuse box. here is the diagram, it is the jump start point under the hood. that is a fuse box as well. they are bigger fuses called PREFUSES so check to make sure there is power at those fuse outlets .

Expert:  Lou P. master tech replied 1 year ago.

have you had any luck?

I have taken my time to answer your question the best i could and i will continue to help if you need follow up information , all i ask is that you PLEASE take a second to rate my service so i may receive my credit for assisting you. Thank you.

Keep in mind then when you rate it does not end our conversation. you can still return here to me for follow up information if needed, Lou.