How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4945
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

Pete Iv'e been waking up to a dead battery that's only 4

Customer Question

good evening Pete Iv'e been waking up to a dead battery that's only 4 mths old & I checked the alternater it's alive and kicking.
After closer inspection I realized over time the PSE module kicking on and off while it's parked in the garage but please note* the trunk does not seat correctly as there is a 1/4" gap it seems on one side of the trunk when engaged(the soft close assist is not working) , I had to epoxy the trunk latch for leaks it seems to work when I engage the key fob. but when the trunk is engaged and I press the fob I have to push down on the trunk to get it to release..but I'm wondering where the PSE comes in??....I leave it closed and locked which brings up the fact that when I press the fob to lock the car the lights start to flash and I press the fob again to get them to stop what is going on????
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.

Hello my name is ***** ***** am a professional here at justanswer and i noticed your question has not been answered yet. I

hope i can still assist with your issue. Keep in mind i cannot see , touch, or hear what you may be experiencing but i

have the automotive knowledge to assist you in the right direction.

It sounds to me like the trunk may not be pulling down all the way and if the pse loses pressure or vacuum it will continue to cycle until it achieves it or until a fault code is set then it will not function the affected circuit. so the first thing i need to know is can you open the trunk and manually press the latch in to close it and watch it close and listen for air escaping, i understand you epoxied a few things but the element pod can still leak air. this may be a hard one to solve over the net but i will do my best to help you. Lou P

Expert:  Lou P. master tech replied 1 year ago.

Here is the rest of the documents., again i hope this helps, Lou P.

Please take a second and click the stars at the top of the screen to rate me so i may recieve my credit , 5 stars is

ideal , please request me in the future. If you feel I have not been helpful please DO NOT RATE 1 or 2 stars AND WASTE

YOUR MONEY , I will opt out to see if another expert can provide more or better assistance so you're not wasting your

money!!. Thanks for choosing just answer. Also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED ! Lou P.

Keep in mind then when you rate it does not end our conversation. you can still return here to me for follow up

information if needed, Lou P.

Customer: replied 1 year ago.

hi lou I got your message and the answer is I can close it and it will latch but it will not lower itself after that.

when I open the trunk and lock the latch manually and press the key it will release.

The attachement I received was for a fuel pump removal????

Expert:  Lou P. master tech replied 1 year ago.

wow, sorry about that, i dont know how i uploaded to you obviously ignore that. sorry.

Expert:  Lou P. master tech replied 1 year ago.

ok did you hear any air leak noise when it latched? did the latch move in as if it was trying to pull in the lid even though it was open?

Customer: replied 1 year ago.

no I did not hear an air leak noise just the pse working, the latch does not try to move in or pull the lid tighter, Im trying to get the proper alignment on this latch now and I will listen closer for a leak

Expert:  Lou P. master tech replied 1 year ago.

Ok it's possible the latch is frozen. It should move out when opened and in when latched. That would cause the kid to not pull down.

Customer: replied 1 year ago.

I haven't got to it yet but when you say latch you are not referring to the metal pull down handle that slides in and out.... that handle is in the out position it will go in when the lid is latched but come right back out.

If you are referring to the pull down action when it is latched, i'm wondering whats going on there as well

Expert:  Lou P. master tech replied 1 year ago.

No I am talking about the part that grabs and pulls in. So when you close the trunk the two pieces that meet each other. I will see about getting a picture and circle what I am talking about. If the handle pulls in the element is working then that means the trunk larch assembly is frozen. Can you upload a picture of the trunk lid in its normal closed state so I can see how far it is from the body ?

Customer: replied 1 year ago.

ok I will try to take some pics n upload

Expert:  Lou P. master tech replied 1 year ago.

Ok thanks!

Expert:  Lou P. master tech replied 1 year ago.

here are some documents

Customer: replied 1 year ago.

ok Lou iv'e got some pics one with the latch before assembly one with a rule and several left and right without rule the left side is flush but not the right and the last one of the latch handle protruding

Expert:  Lou P. master tech replied 1 year ago.

ok, so from what i can tell your rear latch assembly is the issue, it needs to be replaced. it is binding and will not pull in to close the trunk so the trunk remains in limbo, the pse continues to apply pressure or vacuum to pull the lid down and in turn drains the battery. i bet if you pull out fuse 62 for the pse it stays fine and the battery does not die. but that is what i would do.

Customer: replied 1 year ago.

no bet cause that's exactly what Ive' been doing ha ha pulling the fuse under the seat

Expert:  Lou P. master tech replied 1 year ago.

OH, boo, well then you have 2 issues, do you park inside or outside and has it rained since the trunk has been sticking open?

Customer: replied 1 year ago.

I usually park outside but it's been in for a couple of weeks now and yes it rained since the issue and it was outside but no rain entered the trunk...I just went rambo on it and inspected the PSE module which I installed and what's bugging me is that the soft close assist was working before I installed the PSE, is there a procedure for the cpu to recognise it after installation or something

Expert:  Lou P. master tech replied 1 year ago.

Where did you get the PSE from ?

Customer: replied 1 year ago.

i have to check the files, i think rock auto...?

Expert:  Lou P. master tech replied 1 year ago.

Ok pull the fuse and re install it and see if the trunk works if not you may be missing a connector on the latch assembly.

Customer: replied 1 year ago.

i mean does it need to be reset thru a star diagnostic??

Expert:  Lou P. master tech replied 1 year ago.

When you pull the power supply the module codes are erased. So the unit should function. Now the same PSE can be used for a few different models so it may have to be coded to your car before it will work. So if it is new then there is a possibility it has to be coded.

Customer: replied 1 year ago.

well im afraid i'll have to have the dealer code it then...I try to stay away from them since I caught them red handed replacing a brand new part they put on with another brand new part 6 mths later

Expert:  Lou P. master tech replied 1 year ago.

If there are any European shops around your town then it may be worth a call to see if they have a Mercedes style scan tool. Sorry to hear your dealer is not trust worthy. I always made it a point to let customers know we were not the bad guy. Not all techs take the time out. And it's sad.