How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 36039
Experience:  ASE Certs.
7276279
Type Your Mercedes Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 1998 c230 benz. It won't start. It has one code,

Customer Question

I have a 1998 c230 benz. It won't start. It has one code, po507, IAC. I changed the fuel filter, which was original, 150k on the car, fuel flow at the pump, filled up a 1 liter bottle in like 7 seconds, and the pump sounds fine. The car will start, and run, like on 2 cylinders, with starting fluid. I cleaned the MAF, throttle body, etc. still no run, without starting fluid. It has 2 new coils, and new plugs, not from me, someone else. I'm at a loss.Please help, lol
Submitted: 1 year ago.
Category: Mercedes
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Ron replied 1 year ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

In order for the engine to start and run you need good spark to all the spark plugs, injector pulse, proper fuel pressure and good compression. If you can check each one of these things and post back with which one you are lacking I will try and help you get this resolved.

Customer: replied 1 year ago.
Hi Ron, I have good compression, 2 new coils, new plugs, all firing fine, fuel pump sounds good. I replaced the fuel filter, still low pressure at the fuel rail. It runs on starting fluid, but it seems to run rough. Did you ever hear about the fuel line possibly collapsing from the filter, to the fuel rail??? What triggers the injectors, anyway ???
Expert:  Ron replied 1 year ago.

If the pump is running and producing proper pressure and you have injector pulse it really should run, I have not seen any issues with collapsed fuel lines. The injector are ground switch on and off by the PCM (computer) , go back and recheck your fuel pressure as well as the injector pulse.