How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 27862
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

GL 320CDI: We have a 2007 GL 320CDI with about 105,000 miles

Customer Question

We have a 2007 GL 320CDI with about 105,000 miles on it. There have been a number of problems with this car since we got it at 75,000 miles, air conditioning, suspension, oil cooler, and a number of electrical mysteries.
We have had low power and the CEL on for some time. There are 10 codes on my generic reader and they are:
P2009 Intake manifold Runner Control Bank 1 cir low
P0489 EGR control circuit low
P0243 Turbo / Sup Wastegate Solenoid A malfunction
P0111 IAT sensor 1 CKT Range/Perf
P1111 Manufacture control fuel air metering
P0100 MAF or VAF A Circuit malfunction
P1100 Manufacture Control fuel air metering
P0101 MAF or VAF A Ckt Range/ Perf
P1101 Manufactrue Control fuel air metering
P1408 Manfacture Control Aux Emission Control.
We have had it at the dealer and they put a new clean air line on and wanted to replace the DPF which I did not let them do.
I had the DPF cleaned at DPF Regeneration and just installed it the morning and if it was done right that was not the problem.
You answered a similar question about low power and based on your answer I have removed the turbocharger and the stepping motor for the Intake Shut off flaps and they move freely.
Based on these fault codes and symptoms can you offer any advise?
Submitted: 2 years ago.
Category: Mercedes
Expert:  Pete replied 2 years ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
If you haven't had the engine wiring checked for any damage at all I would have it checked to see if there are any wiring faults needing repaired like damaged wiring or loose or damaged engine electrical connections.If this is all found to be o.k. let me know.
Thanks Pete

Related Mercedes Questions