How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

190E: I still have no post start or warm up current to the

Customer Question

I still have no post start or warm up current to the EHA on a 1991 190E, 2.6L. There is 22ma when I turn the ignition on but it falls to 0 when I crank it. Once I get it started and warmed up it seems to go into closed loop just fine. I have checked the resistance of the temp sensor and there is continuity to the ECU. I have no trouble codes or check engine light. I can send about 180ma to the ECU and the fuel pressure in the lower chamber drops just like it should. What else affects EHA?
Submitted: 2 years ago.
Category: Mercedes
Expert:  Marty replied 2 years ago.
Hi, I'm away on vacation until Monday. I will try and help you with this next week if that's ok with you.

Marty
Customer: replied 2 years ago.

I'll wait if I have to. But it seems like you could make some money and still be on vacation without too much investment of time. Smile Unless you're away from your sources of information. This SOB is driving me nuts. There is no telling how generous I might feel in the euphoria of solving the problem. I'd rather give you the money than to continue to waste it on replacing parts.

Expert:  Marty replied 2 years ago.
LOL! It's not me it's my wife! I'll catch up with you on Monday.

Marty
Expert:  Samantha-cssm replied 2 years ago.
We received your customer service inquiry, however, we are unable to respond to you because we do not have your email address. Please contact customer support at***@******.*** and provide us with your email address and a link to this question page so that we can help you. (http://www.justanswer.com/mercedes/964o2-190e-no-post-start-warm-current.html). Thank you, ***** ***** Customer Support Team.