How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask spankyjr1 Your Own Question
spankyjr1
spankyjr1, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 2621
Experience:  I worked on all types of equipment semis,forklifts,farm,ect.
65057319
Type Your Medium and Heavy Trucks Question Here...
spankyjr1 is online now
A new question is answered every 9 seconds

Working on t800 Kenworth with c15 cat. Engine will crank but

Customer Question

Working on t800 Kenworth with c15 cat. Engine will crank but there are no dash icon coming up. It's like the key is off. Unit will not start.
Submitted: 9 months ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 9 months ago.
Thanks for asking your question. I will try and help you out.
So when you turn the key to the on position, the yellow check engine light does not come on?
Customer: replied 9 months ago.
No and everything else that should come on like the ding ding and other dash lights is dead also. It like there is a main ignition relay that is not working. I checked all curses in batter box. All fuses in fuse box that should have power with ignition on do not have power
Customer: replied 9 months ago.
I just jumped power to one of the ignition powered fuse in the fuse panel and it came to life. But obviously it dies as soon as you take power away.
Expert:  Cat Man replied 9 months ago.
I see. I only have engine info. Not chassis. I will opt out and see if another expert can help.
Expert:  spankyjr1 replied 9 months ago.

Hi Shaun What year is this t800?

Check in battery box for a breaker (click here) it will have a #6 cable from battery positive going to it that is what feeds fuse box, see if you have power on both sides of breaker, if not jump breaker.

If not there check by starter inside frame rail

You should have two breakers

on firewall engine side across from steering wheel there should be a cable that feeds power to fuse box make sure it did not come out

let me know

Customer: replied 9 months ago.
anyways got it fixed. 70 amp acc bus relay failed. Thanks anyway
Expert:  spankyjr1 replied 9 months ago.

Happy to hear you got it fixed

take care