How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Automotive Mechanic
Category: Medium and Heavy Trucks
Satisfied Customers: 29130
Experience:  Performed various automotive repairs on several light duty and medium duty vehicles over 15 years of service.
14928985
Type Your Medium and Heavy Trucks Question Here...
Pete is online now
A new question is answered every 9 seconds

I'm working on a 2008 GMC 7500, with a 8.1 gas engine, Altec

Customer Question

I'm working on a 2008 GMC 7500, with a 8.1 gas engine, Altec tree dump and boom upfit. The problem is, the cruise control works normally, but after the PTO is engaged, you turn on the cruise control, then push the resume button to increase the engine speed to the preset speed. The engine speed starts to increase, then drops back down to idle speed of 650 rpm, the engine never gets past 850 rpm, the preset is 1050 rpm, the Altec controls and relays are all good, the module sends power to the cruise wire to the TAC, battery power is available at the TAC when the PTO cable is engaged. Brake, and clutch switch both test good, anybody had this problem before?
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

I see no one has posted any help with this here.In some cases this can be due to the info you may be looking for may be difficult to obtain or the correct person that can help may not be online.

This may be a fault with the TAC itself or the control unit/ecu itself at fault needing replaced.If you have not had the fault codes checked/read out to see what codes are set this should be done.This will require using a scan tool that can plug in and communicate with all computers in this model here.Once this has been done any codes set can be diagnosed and repaired to correct this fault here.If this has already been done and no codes are set let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 year ago.

I have swapped out the tac with a known good one, but, no change. I have checked for codes with a Bosch Tech 2,no codes present.

Expert:  Pete replied 1 year ago.

Unfortunately with my info being limited on this model here I dont have enough info to help fully diagnose this issue but someone else here might have enough info and may be able to help here.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete