How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 5316
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I have a 2006 cummins, about a year ago I started my truck

Customer Question

Hi there, I have a 2006 cummins , about a year ago I started my truck ran good then 1min later truck was shaking sounded like it was missing, engine light came on used my scanner said the code was cylinder 3 injector circuit open , shut truck off disconnected battery cables 15mins. Then started fine no issues for a year, then same thing but cylinder 1 this time open circuit did same thing
Disconnected batteries all was good . I then replaced the valve cover gasket with built in wiring harness thought it was that , then 2 weeks later same thing but cylinder 4 injector circuit open. Had to get towed home still ran like shit , sat for the night then the next day it started up ran fine no issues . Now in morning I get white smoke and quite a bit until it warms up and raw diesel fuel smell, coolant level is ok and oil is ok no fuel smell in oil , could it be injectors ? Or would a reflash on ecm work? Or an electrical issue ? Have you come across this before ?
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 1 year ago.

Hi, My name is***** will be glad to help. If the harness checks good with no opens or bare/shorted wiring then it is most likely injectors. all the symptoms you are having points to injectors, especially the smoke and raw fuel indicating the nozzles are leaking by. That is the first place I would go. However, you could still have some injector driver problems in the ECM so it wouldnt hurt to have it bench tested and reflashed with the most current software updates . Be sure you have good fuel supply pressure and are not sucking air from leaks or have any restrictions between the tank and pump. Let me know.

Related Medium and Heavy Trucks Questions