How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Truck/Bus Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 3382
Experience:  ASE Med/HD Truck Technician, NATEF Diesel Engines and Electrical/Electronics Technician, EPA 608/609 HVAC Certified, Steering/Suspension and ABS/Brakes Technician
9290743
Type Your Medium and Heavy Trucks Question Here...
Jeremy is online now
A new question is answered every 9 seconds

T800 - Bells go off gauges fluctuate, My gosh the red lights

Customer Question

T800 - Bells go off gauges fluctuate
JA: Thanks. Can you give me any more details about your issue?
Customer: My gosh the red lights go off gauges fluctuate up and down all their pressure gauges the temperature readout flashes I fix the cruise control off when it does it
JA: OK got it. Last thing — Technicians generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Jeremy replied 1 year ago.

My name is ***** ***** I will assist you with your question today.

I'm an independent contractor and I don't get paid until a rating has been made. No rate, site gets it all.

We can go back and forth as needed to help resolve the issue you are having. Follow ups are free after ratings, so rate in confidence!

Does the air pressure gauges do it as well?

What year is the T800? What engine is in it?

Check the connections going to the cluster itself. If the plug is loose or the connections to the plug are loose, it will cause that. Power loss to the cluster also causes that. Same with a bad alternator, bad batteries, bad connections at batteries to their connection points. Also check the relay for the ECM to make sure it isn;t buzzing and indicating a bad connection going to it for it can cause this as well.

I'm presuming since you didn't mention it, the truck doesn't shut down, right? Just loss of the cruise control? If so, the cluster itself may be bad, but that depends on if this is happening to just the cluster gauges or even the add on gauges as well. If it has the ad on gauges messing up, then it is definitely a power or ground issue and that will need the dash taken apart to chase the harness to their power/ground points to see what is loose. It's not a easy job and will need a lot of hands on.

__________________________________________________________________________________________________________________________

You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see,

touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback,

they are not the site feedback.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Customer: replied 1 year ago.
all of the air gauges fluctuate except the one that don't is the ground pressure airbag gauge is the only one that does not fluctuate seems to be worse when it is moist outside
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
Its a 2007 t800 c15 cat motor 10 speed transmission
Customer: replied 1 year ago.
When can I expect a response from justanswer
Expert:  Jeremy replied 1 year ago.

For some reason, this question bumped me off and timed out. I'm not sure what happened... I think someone may have looked at the phone call option you posted and I got bumped that way because I don't do phone calls at this time.

Are you getting any codes when this happens? Has the truck been scanned at all? The reason I'm asking is because your dash uses a module on the com link to send you the needed information. If the whole dash is doing it, there is an issue in the com link going to the cluster or the cluster module in the cluster itself is failing.

I would check the fuses and make sure there are no corrosion indicators since the issue is worse when wet outside. Check the ones under the hood. Check that big fat round plug on the driver side main feed at teh fireall as well. Make sure it has no corrosion in it and that there are no signs of corrosion. You can twist the big outer ring to unhook it. It is the main harness connect com link for the ECM, engine, and the rest of the truck. If it has corrosion, then that protection ring is letting water in and causing the come link. Use electronic cleaner spray (parts store sells it for $9.99 a can) and spray it in there heavy. Let it air dry for at least 10 minutes and plug back together. There will be some residue, but that is the slight dielectric grease in the spray to make the connection better.

See if it still acts up. If so, then pull the cluster and have it tested at the dealer. Most likely a connection is loose on the back of the cluster, water is on that plug I mentioned, or the cluster itself is going bad.

If you want to try and do some diagnosing yourself, here is the com link manual. CLICK HERE

Customer: replied 1 year ago.
I can't get that PDF to come up to do some diagnosing myself up early good at diagnosing electronic problems if I've got schematics some paperwork
Expert:  Jeremy replied 1 year ago.

This was checked by 2 other people and neither one had an issue pulling the pdf. There must be an issue on your end. FYI, I'm showing you downloaded it as well...

Since I have no other way to send you the files, I am going to opt out.

Good luck on the repairs and good day.