How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8816
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

I have a cat truck engine, serial 2WS. My make brake is only

Customer Question

I have a cat truck engine, serial 2WS. My make brake is only working on low. The flash code was 14, which is retarder sylonoid med and high open or short circuit. I removed the valve covers and did an ohms test on the sylonoids. They were all 0.008. Then I tested the wire harness to each sylonoid from the outside plug on the head. They all tested o.oo0. Any suggestions on we're to look next?
JA: We'll do all we can to help. Is there anything else important you think the Heavy Equipment Mechanic should know?
Customer: I misspelled jake. Jake brake.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the fully-refundable deposit now. While you're filling out that form, I'll tell the Heavy Equipment Mechanic about your situation and connect you two.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 1 year ago.

Thanks for asking your question. I will try and help you out.

There are only three things that can cause the code 14.

The first and most common is a broken or shorted wire from the ECM to the solenoids. It's pin 10 from the ECM. The ground is pin 9. I would check these first.

Second is shorter or open solenoids. Very rare. I've not seen both solenoids short before. Possible but rare.

Lastly is a faulty ECM. Only seen one faulty ECM cause a code 14 in all my years.

Please reply back if you need more help or have more questions. I am happy to assist.

Customer: replied 1 year ago.
Ok, thank yiu. I will check the 2 pins you sent. Can I also test them with an ohms meter?
Expert:  Cat Man replied 1 year ago.

You are very welcome my friend. I am happy I could help.

Yes you can. There could be a short in the wiring inside the harness or a broken wire. He ground pin 9 is for all the jakes. Not just med/hi.

Please reply back if you need more help or have more questions. I am happy to assist.

Customer: replied 1 year ago.
I will. Thank you very much.
Expert:  Cat Man replied 1 year ago.

You are very welcome my friend. I am happy I could help.

Customer: replied 1 year ago.
I just checked the harness from the ecm to the plus on the outside of the head....the harness is only 10 months old, and all the pins showed 0.000 on ohms meter. I checked from one end of harness to the other.
Expert:  Cat Man replied 1 year ago.

Thanks for the information.

Sounds like the wires are not shorted to another. However they can ohm good and still be damaged or mostly broken. Basically have most of the copper strands broken. When this happens it will ohm good. It only takes a few strands on a wire to ohm good. To verify I like to run new bypass wires straight from the ECM to the Jakes. If the problem continues. I know the harness is fine and the problem is either the solenoids or ECM.

Let me know if you need more help.

Expert:  Cat Man replied 1 year ago.

Hey. I just wanted to see how things were going. Please let me know if you need more help. I am happy to assist. If my information was helpful, please leave a good or higher rating so that I receive credit. Thanks.

Related Medium and Heavy Trucks Questions