How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 5120
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I have 1997 c 7500 3116 8wl02869 while driving engine light

Customer Question

i have 1997 c 7500 3116 8wl02869 while driving engine light will come on and reduce power and keep going then light will come on and shut off pull over and will not start back unless u spay it with starting fluid then it will run for another 10 or 15 ***** ***** and repeat I have .8 volts when solenoid valve is plugged up and 4.5 when it is not plugged up
JA: Thanks. Can you give me any more details about your issue?
Customer: truck will crak
JA: OK got it. Last thing — Technicians generally expect a deposit of about $54 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Customer: replied 1 year ago.
truck cranks and run good like I said it will cut off driving down the road will not restart unless u spray it with starting fluid I checked the volts on the solenoid valve it has .8 if it is plugged up and 4.5 if u un plug it
Expert:  Daniel Wilson replied 1 year ago.

Hi my name is***** will be glad to help. what are you getting for fault codes? If you need to access them you can by holding the cruise set resume switch, key on and count the flashes of the engine light with short pauses in between each digit and a longer pause between codes. Let me know

Customer: replied 1 year ago.
Code is 55
I under that is is saying no falts
Expert:  Daniel Wilson replied 1 year ago.

Thanks for the update. Check for tach signal as if the speed timing sensors lose signal from a faulty sensor or harness the fuel will not be commanded on. I am assuming you verified good fuel supply to the pump and for leaks and restrictions between the tank and pump. Check the speed sensors for loss of signal and let me know if we need to dig deeper

Customer: replied 1 year ago.
Tack has not worked I owned the truck fuil pressure is good it will run up the road full speed why would I have only 4.8 volts the ground pulses not continues my other 3126 has 12 volts and continues ground
Expert:  Daniel Wilson replied 1 year ago.

Your fuel pressure must remain between 65-85 psi at all times and if it is dropping then first go for the pressure regulator at the back of the head. The second cause is a faulty transfer pump

Expert:  Daniel Wilson replied 1 year ago.

The fuel pressure must remain constant even under a load. If the fuel system tests good with a gauge installed then check for loss of speed sensor signal and verify you have good Injection actuation pressure. Should see around 870 PSI cranking and up to almost 4000 PSI at high idle. If low pressure you could have leaky injector o rings, faulty pressure regulator or high pressure pump

Customer: replied 1 year ago.
Not actually checked oil pressure my concern is why do I only have 4.8 volts on the oil solenoid vavle should it have 12 volts like the 3126 in a 1999 FL 60 and the ground is pulsing I think it is something electrical
Expert:  Daniel Wilson replied 1 year ago.

The injection pressure regulator you are referring to correct?

Expert:  Daniel Wilson replied 1 year ago.

The ECM controls the voltage to the IPR solenoid valve and it varies to control the injection pressure depending on RPM

Expert:  Daniel Wilson replied 1 year ago.

Check for good battery power to your ECM that you are getting full battery voltage there. Inspect the harness and connections for corrosion or damage

Customer: replied 1 year ago.
Do u have wiring diagram or a link to site

Related Medium and Heavy Trucks Questions